Ethernet gone after reboot

After install the Ethernet worked great, but after some reboots the ethernet connection is lost and i can’t even detect the ethernet card anymore.

Did a sudo lshw -C network, only WIFI is detected, no Ethernet (enx…). :thinking:

This problem is known with Realtek 8152 or 8153 USB-C Ethernet cards.

A fix was to stop TLP to send certain USB devices to auto-suspend, because they won’t wake anymore.

Ethernet Realtek 8153 (Dell WD15 Dock fix)

sudo gedit /etc/default/tlp

add this lines to the file:


Save & reboot.
This usually worked.

According to the new Ubuntu Budgie version changelog it does not have TLP installed anymore, because of many bugs.
But the Ethernet card is gone again.

Please help. :cry:


lshw should show all USB devices - even those that the kernel doesnt recognised - they will be either blank or marked as unclaimed.

If you can’t even see the USB device then probably you have a hardware issue with the USB device?

The root cause may be a hardware issue, but it could be permanently fixed since years with the USB_BLACKLIST="0bda:8153" line in TLP-config. USB-Ethernet card was always detected after applying this fix with Ubuntu flavors or other distros.
Now it always occurs when the laptop is stuck at boot (Dell Logos showing forever). After second reboot try the ethernet connection is gone and will not recover again.

I like not having TLP installed with Ubuntu Budgie, so i’m searching for a TLP-free fix.

Found a fix for TLP-free distros with kernel udev rules:

USB ethernet adapter (Realtek r8153) keeps disconnecting

See last posting.

ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="0bda", ATTR{idProduct}=="8153", TEST=="power/control", ATTR{power/control}="on"

Put the above in a file: /etc/udev/rules.d/50-cpu-custom.rules

Worked, but after some reboots Ethernet is gone again. :thinking:


It really does sound like the hardware is on its last legs… with intermittent working.

Suggest might be wise to dig deep into the sofa for a few coins and hit ebay/ebuyer or your favourite discounter soon before it waves goodbye.

The USB-Ethernet card is part of a Thunderbolt 3-dock, which is already out of warranty and i don’t want to spend 300$ for a replacement as long as it works with a 1 minute TLP-command fix.
So i’ll give up and install TLP again and replace the new (otherwise better) kernel energy management. :cry:

Ouch… I was thinking $10 micro USB!

Anyway… sounds like you are on the right track

I managed to solve the problem without installing TLP!

Unplugged and replugged the Dell WD15 USB-C dock to disable auto-suspending USB-devices.

Opened Terminal and did:
udevadm info -qall --attribute-walk /sys/class/net/DEVICENAME (<- REPLACE DEVICENAME)

found devicename enx847beb4e1a8c in the folder /sys/class/net/, which is the ethernet-card
This folder will only show if the Realtek Ethernet-card is not in auto-suspend mode.

udevadm info -qall --attribute-walk /sys/class/net/enx847beb4e1a8c

It showed the id “8152” instead of “8153”.

So i updated the config-file:

sudo gedit '/etc/udev/rules.d/50-cpu-custom.rules'

Put this text in the file and save:

ACTION==“add”, SUBSYSTEM==“usb”, ATTR{idVendor}==“0bda”, ATTR{idProduct}==“8153”, TEST==“power/control”, ATTR{power/control}="on"
ACTION==“add”, SUBSYSTEM==“usb”, ATTR{idVendor}==“0bda”, ATTR{idProduct}==“8152”, TEST==“power/control”, ATTR{power/control}="on"

After reboot the Ethernet-card will still work and not stay auto-suspending. SOLVED! :star_struck:

I named the file 50-cpu-custom.rules because i disabled CPU Turboboost to run my laptop cooler:

Add this as last line if you wish Turboboost disabled:
KERNEL==“cpu”,RUN+="/bin/sh -c ‘echo -n 1 > /sys/devices/system/cpu/intel_pstate/no_turbo’"

You can still install TLP and deactivate auto-suspend for USB-devices, but why TLP if we get a better option in the new kernel (my opinion).


1 Like