Extremely tiny mouse in some apps (Qt?) with fractional scaling enabled

In some apps, even those with support for fractional scaling (like DigiKam), everything looks fine except for the mouse. The mouse within the application turns into a baby ant. Even though the application settings allow you to enable scaling for HiDPI (like digiKam). This only fixes the GUI of the application, not the mouse inside the application.

When I try to resize the application, the “resize mouse” has the correct size. When I move the mouse outside the app, over the desktop background, it also turns in a regular sized mouse.

I believe this might only happen with Qt apps. Is there a way to solve it?

Does something like this work … or maybe it was just for qt4 based apps

I asked via the DigiKam mailing list:
I should enable HiDPI for fractional scaling in Settings > Appearance. Then add QT_SCALE_FACTOR=2 to the .desktop execution command. Did all that but the mouse stays tiny.

This workaround doesn’t seem the right way to solve this:

The link you provided, I tried to create the file in several locations ($HOME, $HOME/.config, $HOME/.local) it has zero effect. Alternatively, tried to find a qt-configor similar named package, doesn’t seem to be available.

$ cat ~/.icons/default/index.theme 
[Icon Theme]
Inherits=gnome

The application scales well, it’s really only the mouse cursor, when it is located inside the window.