Can't change mouse cursor size

For some reason, I cannot seem to get the mouse cursor size to change on Budgie Desktop. I have set the cursor size to 48 in “Universal Access”, dconf and ~/.Xresources. The cursor gets large when I’m in Chrome, Firefox and most other applications, but it gets small when the mouse moves over the desktop, panel and Plank. The strangest part of all is that the cursor gets big when it changes to resize or any other shape. It’s only small when it’s the normal pointer.


Setting the size via Universal Access settings seems to work for me - the cursor size was retained over plank, the desktop and budgie in general.

In some apps like virtualbox the cursor size was small over those windows - I guess some apps are deliberately resetting the cursor size.

Playing with themes, icons, and cursors in Ubuntu Budgie, I’ve noticed many times that modifications don’t show immediately, or show partially.

Most of the time you just have to log out and log in back into your session. Eventually reboot.

If you knew how many times I’ve relogged and rebooted, you might cry. Nothing seems to work. I can get the mouse cursor to have a consistent theme everywhere, but changing the size seems to only affect Chrome, Firefox and a few other apps. It seems to specifically be GTK applications that don’t recognize the change. Even KDE ones recognize it.

Edit: I just tried Audacity, and the change actually happens within the app. If I move the mouse to the middle where the tracks are, it gets big, but if I hover over the tool bars at the top or bottom, it gets small again.

I know it’s probably something I did that messed it up. I just can’t figure out what. I didn’t do a clean install of Ubuntu Budgie. I’ve had Ubuntu for years and just recently upgraded to 18.04. I already had Budgie desktop, and the mouse cursor resized fine. I then enabled the Budgie PPA and installed the rest of Ubuntu Budgie. That seems to be when it stopped working.

Is your screen an HiDpi ?

If you have an installation media ( usb or dvd ) you should try Budgie 18.04 in live session ( without installing ) and check there if cursor size behaves as expected.

If yes we’ll know it’s not Budgie’s fault.

You may also try to create a new user on your actual installation and see if cursors work as expected in that new session. If so, then there’s a faulty config’ in the older session.

No, it’s not HiDpi. Other than being ultrawide (21:9), there’s nothing unusual about my monitor. I’ll try the live usb. I tried logging in as new user last night, and the effect was the same. Therefore, it must be some global setting causing it.

Having a large cursor makes things easier for me, but I’m not visually impaired, so it’s not a deal breaker. I just wanted it to be consistent throughout the desktop.

Any graphic card with proprietary driver involved ?

Yes, I have an Nvidia GTX 970 with 396.54 proprietary driver.

For whatever reason, switching from lightdm to gdm3 fixed the problem. Thanks!

Well… good news !

I don’t know if it’s related to my intuition about nvidia.

Gdm3 makes no use at all of Xorg so one may assume the cursor problem is related to a setting « managed » by Xorg which is passed from lightdm through your session, but should not ???

I won’t be surprised after all if it’s still related to nvidia.

Eventually it could be interesting you try with lightdm and without nvidia ( only nouveau as a graphic driver ).

When I have some time off work the week after next, I might try a few scenarios (including open source drivers) to see what the actual problem was, but right now I need a stable production environment with my giant cursor. Thanks again for your help.

Concur; accessibility does not immediately show different cursor. It comes up when it feels like it (no need to log out)