GNS3 Issues - udbridge and python 64 bit

Hi team,

First of all I would like to thank whoever had contributed into this. In last 7 days I have tried many Linux Distros but this one has been best one. It feels light to use all options are these. I didn’t need to find drivers, because my PC is over 10 years old, everything work very well.

However, there are couple of things I have issues with, I am sure it could be due to lack of knowledge in Linux and Python. I am have installed GNS3, now I want get IOU (IOU is like an additional feature in GNS3) support as well. I have managed to install it and to get a licence generated I run a python script. When i run this script i get following error message;

struct.error: ‘i’ format requires -2147483648 <= number <= 2147483647

After googling this error, i understand reason script is not working because its running on 32 bit platform. Can someone confirm whether Budgie is 32 bit or 64 bit? also if someone has a solution as well.

Also I cannot install udbridge as well.

Many thanks,


if you are using 18.04 you have the choice between a 32bit ISO install or a 64bit ISO install. 19.04/19.10/20.04 are all 64bit ISO installs.

Hi Fossfreedom,

Thanks for your help. I will check again my installation.

Kind regards,