GTK2 seems to be broken

GTK2 seems to be broken now for me. Here’s some screenshots of broken apps:

Basically, certain UI elements (a lot) don’t use the system theme. This occurs on all gtk themes, including Pocillo ;( Light themes are usable at least, but still don’t use the system GTK widgets in those places.
This makes UB unusable. I ran into a (similar?) problem in Manjaro with gtk3, though: PLEASE HELP

Any snap packages involved ?

No, both of those aren’t snap packages.

Please dont use the system theme option. It’s there only for legacy reasons when very few themes supported budgie. It is going to be removed in future.

What system theme option? Not sure what you mean

Budgie desktop settings…

But anyway, please can you double check a live iso session … want to see if the observation can be repeated or is specific to you.

I’ve tried, its specific to my installation. So you’re saying I shouldn’t use Budgie desktop settings?

(oh yeah also it occurs with all themes)

The system theme option is in budgie desktop settings

Anyway, that’s not your topic. Is the observation system wide or local to your current account? I e. Login to another account on your machine.

Hmm, I’ll try another account. Never seen a system theme option, I just use the Widget option in Style

@fossfreedom so its system wide. Here’s a screenshot from a brand new user, test:
Of course it’s the pocillo version of my theme, but i tried pocillo with no luck

Wait a second.
Maybe this is me being stupid, but the above pic looks like the correct theme with the wrong colors. However, on my standard user, half the themes look shockingly like Breeze.
Here’s Pocillo-dark:
Now that I think of it, this happened right after I installed some KDE apps, which seemed to install the whole KDE. This command, sudo apt purge kubuntu-desktop^, was supposed to remove the Kubuntu task which i may have installed but just freezes after “Recommended packages”

If you uninstall those Qt apps then you should be able to run sudo apt autoremove and then all associated packages should be removed as well.

Ah, thanks. Will try

Didn’t fix ;( Damn it, this is so irritating.

I FINALLY FIXED IT. I removed the Breeze GTK theme and all the Kvantum GTK themes, and now it works!

1 Like

But that in itself points to a bug. Those themes should never interfere with any gtk themes. I would recommend filing a bug report against those packages.

Right, right. Will do as soon as possible.