How can I show desktop icons?

After adding snome tweak tools and making a siwtch that turned off icons on my desktop I know want them back. How do I get them there again?

just ensure the desktop icons option is enabled in budgie desktop settings

Did you mean some tweak tools or maybe gnome tweak tools ?

Just in case : Budgie desktop is totally different from Gnome(-shell).

To show icons on desktop, you need Nemo as default file manager.

Yes, i mean gnome-.tweak-tools and that perhaps this is taking over some configurations. How do i set nemo to default manager?
Thanks for reply!

It’s the default in ubuntu budgie.

@sigska first follow @fossfreedom’s suggestion and check in Budgie Desktop Settings whether « Desktop icons » are enabled.

Uninstall gnome-tweaks as it has no purpose in Budgie.
sudo apt remove --purge gnome-tweaks
You should also remove all unused or obsolete packages with
sudo apt autoremove --purge

To check if nautilus or nemo are installed
dpkg -l | grep -Ei '(nemo|nautilus)'

If like me you just installed Budgie as a DE on top of an existing install (and not the distro), you might have several file managers installed. Here’s how to check which one is in use:

xdg-mime query default inode/directory

If you want to change your default file manager to nemo (to “open in folder” a downloaded file in Firefox or Transmission for instance) :

gedit ~/.config/mimeapps.list

Look for inode/directory and set it like this:


(or without the nautilus bit)

You should be all set.
Since it’s a user level config, Nautilus will still be used when opening a file from an app you started as root, I don’t believe there are many use cases though.