Is there a way to reinstall or to purge budgie applets?

i have a problem with the language switcher, where when i add the applet, budgie-panel crashes and wont recover, i had it once, but i fixed it by reinstalling ibus, but then it happened again and this time it doesn’t work by reinstalling ibus, is there a way to purge/reinstall or fix the applet?

os version: Ubuntu Budgie 24.04
budgie desktop version: 10.9.1

Best reset your panel to its defaults via this terminal command

nohup budgie-panel --reset --replace &

well, i already know how to reset the panel, but i want language switcher applet to appear on the panel to work and not to crash the whole desktop… is there a way to completely reinstall the applet? via apt or something else

So we need a way to reproduce the issue and then we can fix.

So lets start with your keyboard and language setup.

What keyboards are you using/switching with.? How did you install and configure them?

Ibus?xim?fcitx etc? Again how did you install and configure?

Default locale?

well i use a laptop with the built-in keyboard and it was detected and configured automatically;
i use ibus as the default because it was set like that in the installation;
i use uk-ua locale as the default locale;

i also use gnome session as a backup session and the gnome language switcher works with every input method, i can also switch languages in budgie desktop without the applet, so maybe it’s the applet’s problem that makes the desktop crash…

switching languages is not a problem, but i want the visual switcher, so i know which language i have selected without typing in gnote or any other app with a text box

ok - lets try with some screenshots please.

Take a screenshot of budgie-control-center - language and region tab

Take a screenshot of budgie-control-center - keyboard tab

Take a screenshot of the menu - Language Support

What is the output of locale run in a terminal?

(sorry that everything is ukrainian) (this website wont let me send more pictures since im new in this platform, so 1 pic per answer)

  1. Language SupportSnapshot_2024-06-30_14-57-59
  2. output:
    i dont think that’s revelant, but okay.
  1. keyboard settings
  1. language settings

I don’t speak or read ukranian … so I’ve tried my best to match up what you have in the pictures

So the keyboard layout applet is appearing in the panel for me and I can switch between ukranian and english with it.

I’ve installed gnome-session on top - when prompted I did not select to switch to GDM3 - left it with lightdm.

This didnt appear to impact the keyboard layout applet functionality.

i have literally the same settings but without en_GB (which shouldn’t make a difference), but when i add the Keyboard Layout applet or as i call it language switcher applet (because i forgot how was it called one time)…

this happens! (aka the “something went wrong” screen)

i’ve kinda switched to xfce (for temporary reasons) and somehow i discovered how to run budgie-panel on xfce.
and guess what? the keyboard layout applet doesn’t crash and it works properly… maybe the problem is linked to the budgie desktop…
maybe this is irrelevant but i think it can clear atleast something out.

aha, so i’ve recently have reinstalled libinput and synaptic drivers (because i couldn’t move my mouse while typing in xfce). since it was installed, i’ve realized that libinput provides keyboard stuff, so i checked the budgie session, to know if it was fixed or not. and it was!
right now im in budgie session with working keyboard applet layout and the whole session doesn’t crash!
maybe the problem was with libinput drivers…
well im glad that the problem is fixed.

thx for getting back to us.

This is very unusual - I’ve tried to purge libinput10 (on 24.04) and this is trying to delete the entire budgie-desktop. So I don’t thinks its a missing package. We’ll need to keep an eye on this to find out what part of libinput is possibly missing