Jammy little problems

Hi all,

I know that the first answer I’ll get on this topic will be “go asking AskUbuntu, dear” but nevertheless I would like to know if the couple of problems affecting my installations are pretty mine or if there’s anybody else getting them.

So, first, despite language support (italian and modern greek) is fully installed, my keyboard remains en_US and second, directories sharing via nemo-share gives a 255 error as soon as I try to share anything.

Notice that they aren’t so big problems: for keyboard I’ve added a script in autostart launching setxkbmap it (for greek I simply switch the keyboard layout to polytonic greek) and for sharing I’ve “patched” the problem by modifying /etc/samba/smb.conf, but it hurts me knowing that everything isn’t perfect.

Thanks and best regards,

Nemo share is probably this

Keyboard issue maybe this

Thanks fossfreedom: at least I know that keyboard problem is not my fault (because after first installation I run a script of mine installing a lot of software I need and configuring some system files); the solution proposed in linked topic is the same I’ve adopted: a micro-script invoking setxkbmap :smiling_face_with_three_hearts:

With regard to samba, I’ll continue via smb,conf, until a patch will be released, or I’ll move to nfs shares.


Regarding samba shares, it’s been years I have no success with Nemo.
As a workaround, I use …Nautilus to set the shares and later on it’s okay, no more need for Nautilus.

The keyboard problem is a deal-breaker for me. It did not happen in 20.04, and it does not happen in “official” Ubuntu 22.04 - so far, at least.

thanks and forgive me for being so late … kbd problem has been solved bu official release; about samba shares, I’m still using manual smb.conf modification :wink:


I recently had to reinstall a 20.04 UBudgie.

And still samba share from Nemo does not work. I have to dig further.

Bit out of topic, as you mention smb.conf : when I do samba shares manually through smb.conf ( on linux boxes ) they work BUT they are not seen / listed by Windows ( 7,10,11 ) machines, I have to connect to them by IP. They are correctly seen/listed by other linux boxes though.
What « options / settings » am I missing in smb.conf ?

sincerely I don’t know: my windows 11 machines (one at job and one at home) do see/ list every share … sorry for not being useful


Don’t be sorry ! I appreciate you answered.

silly doubt: I suppose that (if not in an “industrial” network or in a DNS regulated network) windows hosts file is similar to linux /etc/hosts, for what concerns computers list, isn’t it?

If it is, sorry I don’t know (neither understand) why windows pcs don’t see linux ones

Oooh… I’ll have to check that !

Had many OS changes on those computers for last few months…