Home Store Blog Development

Problems with samba Ubuntu Budgie 18.04


#1

I had to re-install Ubuntu Budgie because I changed my hard drive.

So far so good going back to normal after the installation, I just have a problem with Samba.

I don’t know much about “the insides” of Linux, I used to install samba and then with nautilus, open the “Properties” of the folder or drive I wanted to share. Once there, just click on the Sharing Tab, and once there, click on the 3 boxes available (share this folder, Allow other people …. and guest access). And click on Create compar….

That was enough to have my movies or music reachable from my phone or my Android minipc.

But now, though I can see the drives or folders shared, I cannot access them ES Explorer, says that I don’t have permission to access the files.

Please, any help will be appreciated.

Thank you


#2

Hello,

do you access shared directories as guest or as user? Because if you log into shared dirs as user and you don’t have smbpasswd enabled for that user (it could happen if you have reinstalled your OS) simply you can’t log in.


#3

Doing what I do now (exactly the same), I used to access then as guest


#4

Hi,
You said you re-installed Ubuntu.
Did you installed the exact smae version that you had earlier ?
Or did you install a newer one ?

To me that sounds like both devices you’re trying to connect to not use the same version for Samba.
Your device is probably runnng Samba 1 when Ubuntu has Samba 2 and/or 3.

It might be that Samba 1 was enabled in the earlier version and is now disabled or has been disabled.

So I would suggest to check if winbind service is active as first thing and then check what Samba version your device supports.

Regards.


#5

Hi, I am not sure I understand your point.
I re-installed the same version I was running before 18.04.01, I said I changed the hard drive, but actually that is not exactly what I did, I will explain:
I had my system installed in a 1 Tb drive, that drive had several partitions:
-/boot
-/
-swap
-/home
Them I added a 60 Gb SSD drive and following the advice of several webs, I re-arrange my setup, and installed:
SSD drive:
-/boot
-/
HHD drive:
-swap
/tmp
/var
/usr
/home
In order to keep the configuration, I kept the /home partition intact. as I usually have done for years.
I supposed that everything was going to run exactly as before, and everything did, except samba.
Don’t know if this answer your question.
Before, with my phone or the tv-box, both Android, and using ES Explorer, I could see and access my shared folders and the files in them without password or anything and whether they were in my internal hhd or an external one, as far as they were shared.
Now, as I said, I just can see the folders, but I can’t access the files.
Thanx

Pd.- I checked with system monitor and didn’t see winbind running, them I checked with synaptic and saw that winbind is installed together with samba both 2:4.7.6