Keyring popup at boot, how to solve this?

I have read the previous thread, but I don’t see any proper suggestion.

During clean 21.04 install, chosen password was a single digit and autologon enabled.

Now (probably after installing Nextcloud Desktop Client?), I get the Enter password to unlock your keyring everytime I reboot.

What I did:

  • Settings > Users disabled autologin
  • I also wanted to change the pasword, have 4 chars, but that’s not allowed.
  • sudo passwd myusername changed the password.
  • rebooted

Now, keyring still pops up, but it requires my OLD password!

How can I help keyring understand the new password and stop it from asking me everytime?

You need to use seahorse to set a default password as per How to disable keyring in Ubuntu, elementary OS, and Linux Mint | FOSS Linux