Home Store Blog

Lenovo T430s drivers (hardware buttons not working)?

#1

Hi there. I have the above computer.

Is there a patch or drivers available or the hardware buttons and inbuilt fingerprint scanner to work on my Lenovo T430s notebook running Ubuntu Budgie?

Currently, the hardware buttons don’t work located at the top of k/board ie sound mute, volume up and down, mic off etc.

I found I link on Canonical website and it was referencing a Ubuntu 16.04 distro, and no mention of my particular model ie T430s.

I believe they worked (excl. the fingerprint scanner) with Linux Mint.

Thanks

#2

Hardware keys are controlled at the kernel level. Which version of UB are you using?

uname -a 

Above will say what kernel you are using.

#3

ThinkPad-T430s 4.18.0-18-generic #19~18.04.1-Ubuntu SMP Fri Apr 5 10:22:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

#4

Please report this to launchpad

ubuntu-bug linux

The bug triagers will ask you to try a later kernel. It is worth looking at kernel v5 with 19.04 in a live session to see if it all works.

#5

Thank you for your assistance. It seems to be working now, after a reset.

Not sure if I will have issues in the future but I will revisit your suggestion if it persists. Thanks again!