Missing desktop icons

Dearest Ubuntu-Budgie-Community
I’m working with Ubuntu Budgie 17.10 an have lost my desktop-icons (don’t know how this happened). Tried to fix it with budgie-settings and dconf-editor - no chance. Any ideas about this?
Thank you in advance!

I am curious, if you open the fileManager, and click on desktop, do you see them ?

If you can’t see them in the Desktop folder /home/yourusername the problem is that you somehow moved or deleted them

JF

I also read somewhere that with Gnome 3.28.0 (used in Ubuntu Budgie 18.04), Desktop icons won’t be allowed but I am not sure it apply to UB 18.04

JF

Correct. Nautilus 3.26 is the default for ubuntu and Ubuntu budgie. This has the desktop icons feature.

Have you somehow upgraded to nautilus 3.28?

This does not have desktop icons support.

I installed 18.04 Beta on my main production Desktop. If I have Gnome/Nautilus 3.28.0 and still have Desktop icons, should I expect them to disappear when we go to 18.04 final version ?

JF

18.04 only comes with nautilus 3.26. You cannot upgrade to 3.28 without installing it from a 3rd party ppa or if you have compiled it yourself.

You are right.
Took for granted that all Gnome 3.28.0 were " 3.28…"

From TERMINAL
jedi@jedi-HP-Compaq-8200-Elite-SFF-PC:~$ nautilus --version
sys:1: PyGIWarning: Nautilus was imported without specifying a version first. Use gi.require_version(‘Nautilus’, ‘3.0’) before import to ensure that the right version gets loaded.
Initializing nautilus-dropbox 2015.10.28
GNOME nautilus 3.26.3

Hi fossfreedom
Now you mentioned nautilus I just checked my file-manager. I must have changed it to nemo (version 3.6.5) as I can’t stand nautilus. So there seems to be a problem with nemo showing no desktop-icons. Does this have to do with an upgrade? After the installation it worked really well for some months.

Sorry. I have never used nemo. But it must have a daemon process that runs to display desktop icons. I am assuming here that you can removed nautilus? Worth running something like nemo --help to see if there is a daemon process that needs to run. But yeah… it might be that the latest version of nemo might have dropped into the repos and you need to configure it differently to get desktop icons working.

Hi fossfreedom

I’m Ubuntu Budgie 17.10, Gnome 3.26.2