NetworkManager, PEAP and Budgie

Hello all,

in some labs we have set up wired network access with 802.1x security, PEAP and MSCHAP; lab PCs are dual-boot windows10 and Ubuntu 18.04: in windows we use Cisco NAM without a problem, students can login/logout with their credentials and so connect/disconnect to network (better, being or not being allowed to go over the internet).
In Ubuntu I’ve configurated 802.1x security in NM but an username is mandatory, otherwise it isn’t possible to save new connection (or modified existent).
I’ve configured my connection the way it always asks for password (at least, for password, there’s password-flags key); about username, I’ve tried everything: deleting username in /etc/NetworkManager/system-connections/MyConnection , setting username as daisyduck, … but there’s nothing to do: when username/password box prompts for password, user isn’t allowed to change userid field (in Budgie, because in Ubuntu 18.04 standard, is possible, even if I’m not sure if it will be working since we had, a couple of hours ago, to reconfigure everything on test switch, so it isn’t yet time for testing it on standard Ubuntu).

I think that it depends on configuration file being in /etc, so not being “per user” but global and owned by root.

Any suggestion?

This issue?

It links to this old AU article as well

I don’t think, because both links are wireless and (mostly) certificate related. Here the problem is that if I don’t fill user field in NM 802.1x settings, I can’t save it; in other words, I can’t make it working for multiple users.

I’m not so sure that it’s budgie-related but with budgie, in user/pw mask, user field isn’t writable (because already written in /etc/NetworkManager/system-connections/MyConnection file, that isn’t writable by “common” users. In “standard” Ubuntu the same field is editable but I’m not sure that it will anyway work (and for the moment I can’t test because of switch problems).


Hello, I use my Ubuntu Budgie 18.10 laptop at work and the wifi is PEAP/MSCHAP, it requires me putting my username in twice (Ugh!) once next to the domain name (the end of my email I must remeber to check the box that says no certificate is required. Then the username again next to the password I use when I sign on to my PC desktop. It seems a bit long, but the wifi works. My Budgie install remembers my preferences, until the place I work makes me change my wifi password, every 13 weeks.

What’s the trouble? Perhaps I missed it? I’ve trid Ubuntu Budgie on a Dell laptop, a handful of macbooks, an HP Compaq desktop (ethernet only) and a very old Mac Po tower 1,1. Lots of success, and it looks great everytime!

1 Like

Hello Jason and sorry for being so late in answering you,

the problem is that I/we need system not to remember last user or, in other words, we need make possible for several users to log in into PEAP/MSCHAP wifi connection. I mean, normally configuring PEAP/MSCHAP wifi, we must insert anonymous identity, certificate (if requested), userid and password. This way noly one user can connect and if first user logs out and a different user logs in (in the same machine account … is a lab machine, used by dozens of students, technicians and so on, so it would be absurd setting on a new DE for any user), she/he must reconfigure wifi from scratch for using her/his credentials.
What I was looking for is the way to have NM asking everytime for BOTH userid and password e never remember them.

There is a network applet that you could try - this will replace the legacy system tray network icon.

sudo apt install budgie-network-applet

(you need to have our backports PPA enabled)

Does this work in the same way as the existing system tray icon or differently?

thanks, I’ll try ASAP (in these days I’m horribly busy with shibboleth :frowning: )