Home Store Blog

Nvenc Encoding problems on 19.04

#1

EDIT: just install the obs-studio snap with --extra parameter. This resolves the graphical glitches I was having with ETS2 and ATS on Steam and Streaming.

Hi, first off, I am not technical at all. So if this is completely wrong - then apologies in advance.

https://askubuntu.com/questions/778100/how-to-install-compile-nvenc-in-ubuntu

https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

I have tried following these two links and all commands finished with no errors. However, nvenc is still not available on OBS-Studio. It maybe due to this was written more than a yr ago if not longer.

I do not want to use the OBS Snap as it contains a version of OBS that is incompatible with my Gaming Setup and results in graphical errors in ETS2 and ATS.

Any help guidance - greatly appreciated.

Thanks Zeb…

#2

Hi and welcome,

this sounds more of a generic question that the wider Ubuntu community can help with as well. Suggest post on ubuntuforums.org and askubuntu.com - maybe something like

“How do I encode using nvenc encoder on OBS-Studio?”

#3

Hi, Thanks for replying

I know how to encode using OBS-Studio. It needs FFMpeg built with nvenc included.

This was not an issue in 18.04 as FFmpeg was presented with nvenc included.

I was simply wondering does anyone in this Discourse channel know how to encode it given the instructions I posted do not appear to work.

Regards Zeb…

#4

Update - This problem has now gone away as the issue I was having has been resolved in the latest – extra snap of obs-studio

1 Like