Home Store Blog

Video Stutters, stutters

#1

YouTube videos are fine provided I stick to 480p, but news videos from the BBC website stutter on full screen. My computer has 2x 3.4GHz processors and 4GB memory. Everything worked fine until this version 18.10.

#2

What is your graphics card? What graphics driver are you using? What browser are you using?

#3

Settings>About says Grapics NVA8, is that it? The card says GF210. The graphics driver is just whatever Linux chose to use, I don’t know how to check that. Firefox 65.0.1 (64 bit).

#4

I am guessing NV8 is nvidia. Likely that this issue is due to the open source nouveau drivers. As such should use the proprietary drivers.

Open the software update window … click settings … then click the drivers tab. There is usually a nvidia driver recommended. Install that, reboot

1 Like
#5

The process I usually follow with drivers…

# confirm card installed
$ sudo ubuntu-drivers devices

# Add Nvidia PPA to get more recent drivers
$ sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

# Install recommended driver
$ sudo ubuntu-driver autointall

I know this is terminal driven, but just thought I would share.

#6

There was and I have installed it. A quick look suggests that I can now play YouTube video at 720 (not that there’s much point on my computer monitor) and that the BBC News videos now work properly. That’s got to be the fastest fix ever - thanks! There is one oddity, not that it really matters, when starting up and shutting down the logo is oval, it is wider than it is high.

I’ve always been pleased that Linux deals with drivers in the background rather than the horrible battles I had with Windows drivers. However maybe graphics are a special case? I believe someone whose name begins with ‘L’ expressed some discontent at the attitude of some card manufacturers…

#7

There is one oddity, not that it really matters, when starting up and shutting down the logo is oval, it is wider than it is high.

That is due to the fact that in early boot the nvidia proprietary driver doesn’t use the monitor’s native resolution; instead, it defaults to 640x480. On a modern widescreen monitor, such a resolution is stretched more horizontally than vertically. That’s why it looks more like an oval than a circle. It’s kinda silly, but that’s always been my experience with the proprietary driver. Open source drivers, on the other hand, set the correct resolution automatically.

I’ve fixed this issue on my computer by setting the monitor resolution in /etc/default/grub to my monitor’s native resolution. This way, GRUB (the bootloader) renders at the correct resolution, and so does the text mode console after it. I can’t speak to how well this will work for the splash screen as I currently have it disabled. (It didn’t show up for me anyway, just gave me a gray screen during boot. So it seemed silly to me to keep it enabled. I prefer a quiet boot with a black screen anyway. But I digress.)

I’m not at my desktop right now, but I can put my /etc/default/grub in a pastebin when I get over there if you wanna see what I did to make that work.

1 Like
#8

I said “not that it really matters”. However, it may be important to others and I want other people seeing my computer to have a good impression of UB, so thanks, I will use it.
I have had a look at etc/default/grub and it has this,

# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

I will try setting it to the lowest mode which my card supports which is 800x600, so
GRUB_GFXMODE=800x600
I can’t check that it “supports via VBE” (whatever that is) as vbeinfo doesn’t work, nor does videoinfo which was suggested elsewhere.

#9

The name has changed … grub hasn’t caught up with the new name!

Looks like it has changed again in 19.04 … but I don’t know what to

In 18.04/18.10 it was changed to videoinfo

#10

Haha! That was the ‘elsewhere’ I mentioned above.

#11

GRUB_GFXMODE=800x600 Doesn’t do anything, what have you got in /etc/default/grub?

#12

Not sure how exactly I obtained this value, but this works for me on a 1080p monitor:

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1920x1080x32
GRUB_GFXPAYLOAD_LINUX=keep
#13

Doesn’t seem to work, never mind, it’s no big deal.