Home Store Blog Development

Ubuntu Budgie 18.04 booting screen


#1

I created a bootable USB drive from the iso 64bit I downloaded from the site, and used to install UB on my notebbok. everything works great.
I have an issue on the boot process.
When I boot my notebook the first screen I see is a Gray screen with no info text or anythin. the after a few seconds I see a screen with the ubuntu budgie logo for less then a second the screen turns black and the login screen comes up.

someone could tell me if this is the normal expected behavior? I imagine that it should work as the Ubuntu 18.04 boot sequence works. there is a fix?


#2

What graphics card and graphics driver are you using?


#3

My notebook has an hibrid system with an intel UHD 620 for low performance and a Nvidia GeForce MX150 for high performance. I am usin the Nvidia Drivers.


#4

Ah. Yes. The observation you see is due to the use of nvidia’s proprietary drivers.

As far as I understand it those drivers do not support the KMS system needed for a smooth Plymouth boot screen. Only the open source drivers support the KMS system.


#5

do you know of any big difference between Nvidia and Nuveau drivers?


#6

From reading phoronix - the proprietary drivers are much faster and work for all nvidia cards. The nouveau drivers are much slower and there are a number of nvidia cards they do not/only partially work against.


#7

Thanks. for the information


#8

Hi,
I do not think the answer is very accurate.
I use an AMD GPU (Radeon R9 Fury X and RX 580).

I haven’t installed any proprietary driver for that.
It’s ubuntu-Busgie ootb.

Still, I have the exact same problem.
And that is really annoying…

I tried to reinstall GRUB, I tried to install proprietary drivers, I tried several things… But nothing to do.
Still that stupid grey display on boot !

Regards.


#9

its the same issue - the KMS part for the radeon driver (in your case) hasn’t kicked in. That is a bug in the driver. Other AMD cards do work just fine.


#10

Hi,

Thanks for taking time to reply to me.
You are indeed probably right.
I just updated to kernel 17.10.
And guess what ? Boot screen with options to select boot kernel.
And the nice thing : if I then decide to boot from another kernel, I still keep the boot screen :slight_smile:

Regards.


#11

17.10? You mean kernel 4.17.10 ?

If so - great news. In Jan/February the hardware-enablement-support will kick in for 18.04 LTS and you will have the option to use the 18.10 kernel i.e. v4.18 - every 6 months thereafter you will then be uplifted to the latest supported kernel.

That should help you stay on a supported kernel … and have your boot screen working :slight_smile:


#12

Hum… I am a little unsure about what allowed me to have the boot screen showing up the boot options.

It can be either :

  • switching to a higher kernel ;
  • setting the BIOS on the Motherboard to boot the GPU in “Legacy” mode, instead of UEFI.

I will investigate a little further and report here of course.

Regards.


#13

This is interesting. How will this option be visible??


#14

That will be advertised in the next month or so.

From 16.04 experience … what happened is that the 18.04.2 point release will automatically have the updated kernel.

For other users who started from 18.04 and 18.04.1 there will be a simple one line command line entry you use to uplift to the HWE stack.


#15

Hi,
Well, I messed up with kernel and BIOS again and wasn’t able to get back the boot screen to display the available kernels.
This is really no cool as it is somewhat difficult to get back to another kernel without that option :frowning:
Hope as you said, that new feature will enable it :frowning:
Regards.


#16

Usually you have to press and hold the shift key at the start of the boot sequence to display grub … then select the kernel you want in the advanced option.

Some people find pressing escape works better than the shift key to display grub