Raspberry Pi5 and Jammy

Hi all,

yesterday my husband came home with a brand new Raspberry Pi 5 8Gb as present :smiling_face_with_three_hearts: and only few minutes ago I’ve been able to test it; I’ve inserted the Jammy card that runs on my Pi 4 and … nothing happened! Is possible that is a OS problem? I mean I remember somehow to have read that Pi 5 works only from 23.10: is it correct or (hopefully no!) is a Pi 5 problem?

Thanks and nice weekend,


Correct. 23.10 has full support for the pi5.

My understanding is that pi5 support will come for 22.04 LTS but only when the 23.10 kernel drops into the archive on jan/feb 2024 timescales

1 Like

OK, I’ve tried to install budgie on my Pi5 and something failed; I say something because I honestly don’t know how to get access to the system: blank screen with blinking cursor, no ssh (connection refused) and Ctrl-Alt-Fn not working to get at least access to a teminal login. More, I’ve downloaded, installed and correctly accessed Ubuntu 23.10 “standard” and it works. Then I’ve installed budgie DE on it and now I’m unable to get access again, so I suppose it’s matter of lightdm not properly working …

Now I’m reinstalling “classic” Mantic: I prefer gnome than nothing, but I won’t customize it so much since I’d like to use Budgie.

Thanks and nice we,


If it is lightdm then definitely something to report to launchpad.

If you are up for some experimenting try

Ubuntu standard

For the later when installing make sure when prompted to default to sddm as your login manager

Hi fossfreedom: no way, even if now it’s telling something more (something that I don’t understand, anyway): it reaches the point you can see in attached picture (sorry for bad picture: I’ve taken it on the fly with my mobile) and then stops with that blinking cursor :thinking:


Feels like a kernel bug.

Try disconnecting the monitor. Restart the pi and after 30 seconds reconnect the monitor.

Any changes?

Sorry, a beloved nothing … SNAFU🤐

shut down everything then tomorrow I’ll reinstall standard Ubuntu, waiting for 24.04, hopefully!

Now, it’s about time for cinema :star_struck:

Have a nice evening,

I’ve tried installing (on raspberryPi 5 with Ububtu standard onboard) ubuntu-budgie (not the whole environment) and, while a test on a Pi 4 has been successful, on Pi 5 still problems …

In this case OS starts, it doesn’t stay “frozen” as described above, but if I choose budgie as DE, session ends soon and I’m kicked again to login window. Accessing with statndard Ubuntu and taking a look to /var/log/auth.log I find:

2023-11-16T18:57:05.809066+01:00 raspie5 polkitd[664]: Unregistered Authentication Agent for unix-session:c4 (system bus name :1.184, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale it_IT.UTF-8) (disconnected from bus)

every time I try to get into Budgie.

I don’t understand exactly that message, but I hope that it will help; notice too that if I install lightdm, then raspie doesn’t start as when I try to boot with a “pure” budgie.

Doubtful that’s the issue itself.

Probably if you switch to a TTY after failing to login via lightdm, login and running journalctl -ae --full will have more meaning messages

login_error.txt (819 Bytes)

Hi and thanks. I’ve done as you suggested but honestly I’'m not so able to understand everything in journalctl, so I’ve attached it in here. At a first glance it seems that something happened in line 169 neighbours, but I’m not so sure that my look was correct.

BTW, I’ve tried to install cinnamon on Ubuntu standard (the only that works) and … same problem as with Budgie: kicked off and only Ubuntu standard accessible.

nice weekend,

Ah. Sadly it appears you have attached the wrong file.


journalctl -ae > ~/output txt

sorry, I had on my pc two files with similar filename (the one I’ve taken yesterday from auth.log and the journalctl export taken today) and I’ve attached the wrong one :unamused:
journalctl_raspie5.txt (117.5 KB)

'fraid there isn’t any evidence of lightdm running in the log - nor do I see any evidence of budgie running.

It appears you are running gdm3 - gdm3 is failing to start because of a graphics issue - it doesn’t recognise the monitor you are using on card 1 - card0 appears to be ok - are you connecting to two displays?

Hi and thanks,
no, just one monitor connected, however, via an hdmi to vga adapter. I’ll try to change video slot , cable and monitor too (just discovered yesterday that my main monitor has two hdmi input, one of which is for the moment free, so I’ll try with that one - and freeing space on my room too, since the second monitor will be useless :wink: ).
But anyway, if I try to start with “native” budgie MMC, it doesn’t start at all

Hi again

I don’t know if it makes some sense but, feeling that it could be a problem somehow related to x and/or lightdm, I’ve started my raspberry5 with budgie-mantic and, obviously, got that error again (no way to go on graphics environment).
This time I’ve been able to log into shell with Ctrl-Alt-F5, then installed (copying deb files on an usb key, because I needed to authenticate against our firewall before getting internet connection) lynx and finally ssh. This way I’ve been able to get some logs and save them with a bit of comfort more (ssh-ing from my jammy). Notice that I’ve installed sddm too but I haven’t anyway been able to get graphical environment, while with gdm3 (and rapberryOS too) it worked.

Here you can find some logs I’ve collected (unfortunately isn’t possible to upload tar.gzipped files, so I’ve attached a big logs collection …); there’s always a “Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices” before SIGABRT signal and X server stop

various_logs.log (34.5 KB)



Yes - I would concur with you that this is definitely an xorg issue - its probably something missing by the pi5 xorg stuff that lightdm needs

Under GDM it probably is not invoking the same xorg requirements.

Please do file a bug report against linux-raspi initially OpenID transaction in progress but I suspect it will then be moved to another xorg related package.

Attach your “various_logs.log” file to the bug report.


ok thanks, I’ll do.
Just a question more, probably an idiot one: since oem installation works w/o problems an since issue occurs only after reboot, wouldn’t be possible that it depends on some packet present in oem installation but then removed? Or is just hopeful fantasy of mine?

thanks and have a nice weekend


Hi fossfreedom,

I’ve opened a bug ticket two days ago (Bug #2044718); it’s still in “new-undecided” status, but someone recently added a tag “kern-8618”; I suppose that’s involved the kernel but can you tell me what “kern-8618” means?


Thats an internal Canonical ticket number - so currently its with the Kernel team. Lets see where this goes.

Really appreciate you raising this issue.

1 Like

I came across this thread whilst googling RasPiOS Bookworm Lite with GUI on Pi5 - Raspberry Pi Forums

Its the same message you have in your logs.

It mentions installing gldriver-test - thats a package for raspberry os available here Index of /debian/pool/main/g/gldriver-test

Absolutely no idea if the 0.15.deb will work on ubuntu - but if you are up for more testing well worth downloading this .deb and installing it i.e. change the the folder you have downloaded to and run

sudo apt install raspi-config
sudo apt install ./gldriver-test_0.15_all.deb