Rebinding Alt+Q

Hi,
I can’t for the life of me find out where the Alt+Q(and F12) pulling up Tilix in Quake mode is bound, and how to clear it to to use for something else. I’ve been trying to search for relevant options with dconf-editor with no luck.

What version of UB are you using?

19.10, just cleanly installed.

Create a folder called ~/.local/share/budgie-extras-daemon

copy the files tilix_alt.bde and tilix_f12.bde found in /usr/share/budgie-extras-daemon into your local folder that you created above.

Edit the command you want in the .bde files that you want to bind the shortcuts with.

Logout and login.

2 Likes

Doesn’t work for me.
Ubuntu Budgie 19.10.

The steps I took:

  1. Copy the file tilix_f12.bde found in /usr/share/budgie-extras-daemon into my local folder ~/.local/share/budgie-extras-daemon.
  2. In file ~/.local/share/budgie-extras-daemon/tilix_f12.bde I changed line “shortcut=F12” to “shortcut=<Alt>F12”.
  3. As a result, Tilix still appears at the F12 pressing, but now it also appears after Alt+F12 pressing. Of course, this in no way solves the problem.

But thanks to this topic, I found another solution. For me, the problem was solved by completely deleting the file /usr/share/budgie-extras-daemon/tilix_f12.bde. I realize that this is not the best solution, but I don’t see another solution yet.

By the way, it’s rather strange to use such frequently used keys as global shortcuts. For example, F12 is used in Firefox to call the code inspector window. The same F12 key is used in Blender to launch a render window. And it was an unpleasant disappointment for me when, after upgrading to 19.10, instead of the render window in Blender, I got a Tilix window. Even more annoying that there was no quick fix, because the intuitive way to open the Tilix settings window and change the keys does not work.

Yours is a different issue. Good find. We need to find a way to disable a keybinding rather than deleting a system file.

Raised here to think about

1 Like