Reinstalling Budgie 18.04.03 LTS

I am having issues with Budgie 18.04.3 LTS and thought that I would just install and start from scratch but it seems that my OS has become sentient and is fighting my efforts. Here is what I have done:

I downloaded the package off of the website and made a bootable disk with ubuntu-budgie-18.04.3-desktop-amd64.iso using the Startup Disk Creator. When the computer was restarting, I hit F12 to go into the BIOS menu and selected “Removable Devices”. However, it then just restarts normally. It doesn’t bring up the dialog box and I am pretty sure that it is not reading out of the USB. I have tried this on all of the USB ports to the same effect.

I found a post saying that it has to be installed with a USB but I am not sure how to proceed if it won’t recognise my flash drive. Undaunted, I searched around and found instructions to reinstall from /home (I can’t find the page where I read this but I thought that it was somewhere in I moved the .iso file into the home folder and then went to tilex and entered:
sudo mkdir /media/cdrom
cd ~
sudo mount -o loop ubuntu-* /media/cdrom
It brings up a box showing the .iso file on the USB and in the home folder but I am really not sure what to do with this information. When I click on either, it just brings up a menu with all of the folders.

Can someone give me steps to just reinstall the OS entirely? I am not worried about preserving files or settings, I just want a clean slate. Thank you!

I would have a look at this link.

It “sounds” like the ISO was not written as being bootable on your USB stick.

I have also use the program called “Etcher” in the past.

Try GNOME Disks. It’s awesome, as long as you’re on a linux platform.

Thank you. I ended up making another boot disk and that one worked so I am reinstalled and problem free!

Both startup-disk-creator and etcher create a iso9660 filesystem on usb key (so that if you want reuse your key you’re obligated to re-create partition table on it) and, obviously, doesn’t allow persistence.
Installing grub into usb-key and working a bit on it allows you to build a “multi-iso” key but in this case too persistence doesn’t work.
Other packages, like mkusb, allows persistence but do a real mess into the key.

Stated that having persistence on usb can be a good thing only if you use it as “rescue” unit, it would be nice if there will be (back) something like old versions ('til 2.6.7) of startup-disk-creator …