Booting ISO in dell precision 7740

This is not really a budgie issue but I am unable to boot Ubuntu budgie into my new dell precision 7740. The following were done in bios -
a) secure boot off
b) set SATA settings to AHCI
c) there is no legacy option only UEFI
d) enabled USB boot support and external USB port
e) tried to add boot option but not able to see EFI directory and Shimx64.efi to add the path under file name option

Any help would be appreciated as I have tried to look into a lot of sites but not able to go forward
Thank you and have a great day

what software have you been using to write to your USB stick?

Have you tried another USB stick?

Did you double check the md5sum of the ISO?

Thank you for your reply

I used Rufus for writing the usb stick…

No I didn’t get another usb stick… will it make a difference? I can try that if that is a factor

I did not check the md5sum. I use Ubuntu budgie on my old MacBook Pro and it never had an issue

Let me try both the above and then get back but is there anything I need to do additionally in the laptop bios settings also?

Appreciate your support and thanks again

If the stick is failing this can prevent booting of an ISO - i’ve had this before myself.

Well worth checking just in-case the ISO itself is corrupted to prevent the ISO boot.

What you have listed looks ok to me

Additionally - if you are dual booting with windows - then ensure you have turned off fast-boot via windows itself.

Thanks again.
I’m not dual booting with windows. I’m trying a full install. The fastboot option is set to “thorough”.
I will do both the steps and let you know

Thanks a lot for your quick response. Much appreciated

Hi, the iso was corrupted and hence rewrote the stick again. It is booting now.

Now trying to fix the issue of blank screen after grub menu.

Thank you for your quick support and much appreciated