Second monitor doesn't switch workspace

I installed 19.04, but I’m having trouble with my secondary display. When I switch to another work space, my primary display (laptop) switches, but my secondary monitor stays where it is, i…e, it doesn’t follow my primary to the other work space.

I upgraded a few hours ago, so I may have missed a configuration option, but I couldn’t find anything obvious.

Hi and welcome.

as far as I can gather, workspace switching only works on the primary monitor.

Guessing this is really an enhancement request upstream -

1 Like

Hello, thanks for the reply!

Correct, currently only the primary display switches when changing workspaces. This was not the case before the upgrade to 19.04 where all displays (or just both in my case) changed to the new workspace (or to put another way, remained at the workspace the user switched from).

Is a previous functionality an enhancement request?

To be honest … I dont have a two monitor solution available to me to reproduce.

Since you are saying that it previously worked, then it isn’t something that budgie did itself. There are no changes made by the budgie team in this area.

So the change must be in the GNOME area … mutter probably.

So a change there would impact. I dont know if there are dconf settings in the mutter area under org.gnome available.

Otherwise it may need a code change to trigger the behaviour.

Speculation on my behalf. Sorry. Dont have the equipment to reproduce and help here.

1 Like

Understood. Thank you for the reply.

Does toggling this dconf key via dconf-editor help?

org / gnome / mutter / workspaces-only-on-primary
1 Like

Sorry for the late reply.

That looks like what I want, but I’m trying to figure out how to make the dconf setting persist after making the change.

It’s persisting now, but the desktops are still not switching in unison. It really kills the advantage of having multiple displays.

I am running budgie 20 and had the same issue out of nowhere but the answer on this article fix it for me

I just ran: gsettings set org.gnome.mutter workspaces-only-on-primary false


This worked. Thank you :slight_smile:

I’m running 20.04.

This worked for me also (July 2021). I just upgraded from Ubuntu 16.04 (running Unity) to Ubuntu 20.04 (using the Gnome desktop). I couldn’t figure out why switching workspaces only switched my primary screen. This setting solved it for me. Thanks!

This worked for me also,
Thanks man. 20.04

That’s weird. I never touched that setting and yet it’s always worked for me, either on Manjaro or on Ubuntu. But I added Budgie to an existing Ubuntu install rather than installing Ubuntu Budgie (get the difference?).
Could this stem from the specific default Ubuntu Budgie configuration? Maybe changing the default behavior should be considered then.