Shut down and wifi applets

Some blip, it appears, caused the shutdown and wifi applets to disappear from the top menu. No amount of searching the applets produces either of these as a choice. I installed Gnome Tweaks but it offers no controls in this regard. I also tried sudo apt-get install indicator-session
also to no avail. Is there a way to either restore the original top panel or add these two applets?



To reset the panel run

nohup budgie-panel --reset --replace &

I tried that and got

nohup: ignoring input and appending output to ‘nohup.out’

The panel did not reset even after logging out

ah - the perils of typing on a phone!

two dashes preceding the “replace” - I’ve edited the above

THAT did the trick!!! grazie!

that fixed a few other problems. There were 2 instances of dropbox and HP device mgr

FYI Tried to reset again using “nohup budgie-panel --reset --replace &” Terminal came back with “nohup: ignoring input and appending output to ‘nohup.out’
[1] Done nohup budgie-panel --reset --replace”

It took three tries to get the “done” message, and then it restored what I had lost.


I was making adjustments to the top panel again and lost some elements I want and could not find to add them back in. So I reset the panel again and got this

$ ** Message: 18:30:54.402: manager.vala:562: Resetting budgie-panel configuration to defaults
** Message: 18:30:54.403: manager.vala:451: Resetting dconf path: /com/solus-project/budgie-panel/
** Message: 18:30:54.522: manager.vala:625: Creating default panel layout
** Message: 18:30:55.189: libsession.vala:50: DESKTOP_AUTOSTART_ID not set, session registration may be broken (not running budgie-desktop?)

(budgie-panel:4572): GLib-GIO-WARNING **: 18:30:56.029: Received property Position with type i does not match expected type x in the expected interface

** (budgie-panel:4572): WARNING **: 18:30:56.163: BudgieMenuWindow.vala:190: Software has no parent directory, not adding to menu

The top panel is restored until I log out of terminal.

What’s up with this?


Sounds like you have uninstalled something budgie was expecting.

Check by installing the critical packages again:

sudo apt install --reinstall ubuntu-budgie-desktop budgie-desktop-environment budgie-desktop-common budgie-desktop budgie-core libbudgietheme0 libraven0 libbudgie-plugin0 libbudgie-private0

logout - login then reset the panel again:

budgie-panel --reset --replace &!

Logout and login again.

Before I received your repeated nohup budgie-panel --reset -replace &. This time it worked. I will keep your additional instructions in case I have issues again.

Thank you very much for your assistance