Startup - unable to access startup on mac mini (2012)


Decided to upcycle my 2012 mac mini (i5 2.5Ghz).
I followed the Ubuntu guide on how to create a live-usb with Etcher on macOS.

I tried a couple distros using the live-usb and always got into the startup by hitting the OPT key on a cold boot-startup.

I went ahead and installed U-Budgie. For some reason I chose ‘minimal’ during the installation process which I now regret. Not sure why I did that - I figured I would add what I needed one by one but now I realise I am pretty much gonna need all of it - although not exactly sure what comes in a full installation, but for I already needed to install gnome disk and I now need a pdf reader

So, I decided to reinstall Budgie but now I am unable to access start up!

I have a Logitech MX wireless keyboard and I understand that can cause an issue but as I say, it has worked before. I’ve tried variations and combinations, hitting the OPT key on either side of the spacebar, holding it down on start-up, hitting it in rapid succession (which, as I said, worked before) and in combination with cmd key in desperation.


It looks like I am stuck in Budgie. I wasn’t completely set on this being the distro for me. Had a few issues already which I was going to open topics about but now, that can wait!

  1. Any suggestions on getting into Startup so, I can choose Volume to boot into?

  2. Are there specific packages to get a Budgie minimal install up to speed? I feel like I am missing utilities and perhaps some other basic packages and features. If I need/want Libre Office, I know I can just go and install that…so, I don’t mean that. More just in general, getting it to a fuller version of Budgie

Appreciate your input and suggestions

Probably something like:

sudo apt purge ubuntu-budgie-desktop
sudo apt update
sudo apt install ubuntu-budgie-desktop

Thanks, for such a quick response!

I was just trying again to get into Startup. Found an old Dell wired keyboard but still no joy
So, maybe best to get on and try and make this installation work
When you say “Probably” …how probable though? :grimacing: I would hate to break this install given that I am seemingly stuck with it, at least on this SSD. Maybe, someone can confirm?

It wouldn’t do any harm - ubuntu-budgie-desktop is the meta package for ubuntu budgie.

The minimal install installs via ubuntu-budgie-desktop - and then uninstalls a whole bunch of packages that were previously installed.

So the idea here is just to purge the package and install again.

I don’t have a mini I’m afraid - with my macbook pro 2012 I just press and hold the opt key immediately after power on to display the USB selection window.

1 Like

Ok, thank you…I’ll give that a whirl and see what happens.

Is there a command I can type afterwards or how to check whether I am then have the full installation of U-budgie?

if you can see apps like lollypop and system-monitor (mate-system-monitor) you have the full install.

EDIT - I’m assuming you are using 22.10 - those are 22.10 applications

22.04 - rhythmbox and system-monitor (gnome-system-monitor)

1 Like

…looks good. Thank you.

Are you happy with Budgie on your 2012 MBP?
still find it strange that I am no longer able to access startup since installing Budgie but good to know its working on yours. Maybe, its something I’m doing after all.

Works just fine here. I tend though to use this laptop to install new releases and test releases of UB so it gets blasted pretty often.

1 Like