Steam installation problem

Hello there!
I am trying to install steam but i get these errors and i can not proceed.
How do i fix it?
Thanks!

The following information may help to resolve the situation:

The following packages have unmet dependencies:
xdg-desktop-portal : Depends: default-dbus-session-bus or
dbus-session-bus
Depends: fuse
Depends: libc6 (>= 2.28) but it is not going to be installed
Depends: libfuse2 (>= 2.9) but it is not going to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
Depends: libglib2.0-0 (>= 2.63.3) but it is not going to be installed
Depends: libjson-glib-1.0-0 (>= 1.4.2) but it is not going to be installed
xdg-desktop-portal-gtk : Depends: dbus-user-session or
dbus-x11
Depends: libc6 (>= 2.14) but it is not going to be installed
Depends: libcairo2 (>= 1.2.4) but it is not going to be installed
Depends: libfontconfig1 (>= 2.12.6) but it is not going to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
Depends: libglib2.0-0 (>= 2.45.3) but it is not going to be installed
Depends: libgnome-desktop-3-19 (>= 3.17.92) but it is not going to be installed
Depends: libgtk-3-0 (>= 3.21.5) but it is not going to be installed
xterm : Depends: libc6 (>= 2.15) but it is not going to be installed
Depends: libfontconfig1 (>= 2.12.6) but it is not going to be installed
Depends: libfreetype6 (>= 2.2.1) but it is not going to be installed
Depends: libice6 (>= 1:1.0.0) but it is not going to be installed
Depends: libtinfo6 (>= 6) but it is not going to be installed
Depends: libutempter0 (>= 1.1.5) but it is not going to be installed
Depends: libx11-6 but it is not going to be installed
Depends: libxaw7 but it is not going to be installed
Depends: libxext6 but it is not going to be installed
Depends: libxft2 (> 2.1.1) but it is not going to be installed
Depends: libxinerama1 but it is not going to be installed
Depends: libxmu6 but it is not going to be installed
Depends: libxpm4 but it is not going to be installed
Depends: libxt6 but it is not going to be installed
Recommends: x11-utils but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

From where are you downloading steam?

What is the command you are using to install steam?

From steam Steam, The Ultimate Online Game Platform
I do not use a command its an icon on my desktop (from properties i see its type is Text (application/x-desktop))

Drop to a terminal

cd ~/Desktop
ls *.deb

Whatever the .deb filename is run

sudo apt install ./filename_of_steam.deb

I got the same response

PS:If forgot to mention it when it shows me this message on the terminal it pops up a window about a missing library libc.so.6

Can I ask why you are downloading steam rather than installing the package that’s available in the normal repositories?

sudo apt install steam

I like more the graphical style

i tried the sudo apt install steam and it did the same thing

Here will attach pics maybe it will give a better understanding
p1

Hmm… what version of Ubuntu Budgie are you using? 20.04?

Yes i use the verion 20.04

What have you tried from the answers here?

Tried the 1st and i got this

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc6-i386 : Depends: libc6 (= 2.31-0ubuntu9.2) but 2.31-0ubuntu9.3 is to be installed
E: Unable to correct problems, you have held broken packages.

The last gave me the same thing.

2.31-0ubuntu9.3

That version of the libc6 package doesnt exist in the ubuntu repos.

You have most probably added a repository such as a PPA that is messing up the 32bit library that is needed.

At a minimum I would suggest you investigate further targeting the extra repositories you have added. Look carefully at the package ls available in that repo. If it is a PPA then you should ppa-purge the repo. If it is an external repo then things will be much more difficult to reverse especially if you are a newbie at all of this.

If in doubt … dont install random repositories without first investigating what packages that repo is providing and could conflict with the main ubuntu repos.

I found some PPA steam, i have purged steam