Steam not working (20.04)

hi, I am fairly new to Linux, and definitely new to budgie.

I have had a great time, not that smooth transition from windows, but I have loved ubuntu budgie so far. One of the problems I haven’t been able to fix are Steam.

I have tried installing from the snap store, the budgie default store, and flatpack. I have been able to boot into it, but it didn’t access my external drives(I need this because my internal storage is 50GB). I have seen many guides into how to “fix” it, but it just made it worse… (I can’t even access steam anymore). I haven’t found anything else in this manner, and while I still have windows, I would like to play rocket league on Linux.

I have an intel laptop, with a 1660 Ti

Thanks in advance

Hi and welcome.

Since this is not a budgie specific issue, other support forums I would warmly recommend are and

A quick look I found this similarish Q&A

Hopefully a wider audience via one of those two forums can also help here.

Thanks a lot, I’ll check it out

Just reviving this topic as I am also unable to solve this probem, there are dependencies unmet and whatever I do, it is not fixable. This does not seem to be an Ubuntu issue, as after Googling, the provided solution works for other Ubuntu distributions but not for Budgie :frowning:

I posted my own question even, but got confirmation that the steps I have taken should have solved it:

1 Like

Any ppa regarding graphic drivers ? See rtaft’s comment who suggests to check your /etc/apt/sources.list and /etc/apt/sources.list.d/