Testing 20.10 - only for the most adventurous

Following the raising of this topic .deb packages open via zip file manager by default we will now ship with a defaults file extension file - i.e. what app that should be opened when you double click a file e.g. file.txt should open with our default text editor GNOME edit.

This will resolve the raised issue of .deb files not opening in gnome-software by default.

This will also resolve picture based files (png/jpg etc) should be opened in our default viewer gthumb

We do need confirmation that our mapping of file extension types map and open correctly by our default apps. please help us to confirm this.

1 Like

Will it be a hard dependency for Budgie on Ubuntu or just a file installed when installing Ubuntu Budgie?

I wouldn’t want it to override one that already exists for example and change all my current default apps.

Anything local will always override a global setting such as this file

Does fixing some translation issues fit in here ?

One is about app-menu/parameters, the other’s about « disconnection » notification.

Fun fact, the « connection » notification is correctly displayed in my language.

…and a print screen key that does not get broken every now and then…

1 Like

Translation issues can only be resolved by translators of the project in question.

As to print screen. I haven’t ever seen it broken. So a method to reproduce this is the only way to resolve.

Not really new → Screenshot shortcuts not working (by default?)

For some days or a couple of weeks, the print key does nothing on my UBudgie 20.04.

Well to be honest, most of the time it does nothing ( expected is : save full screenshot to folder ).

I’ve just noticed there were also settings for screenshot and keyboard under /org/gnome/settings-daemon/plugins/media-keys/ that were different than in /com/solus-project/budgie-wm/ or Parameters/Keyboards.

It’s quite a pain to have to check 3 different places for just one feature…


Having same settings in these 3 places seem to fix my issue for the moment.

Another annoying thing is, for months / years maybe ? screenshot seems unable to apply dropped-shadow straight to a window, it adds twice a dozen pixels all around the targeted window. That did not and still does not happen in Unity 16.04. I’d expect something like :

grossly made in Gimp.

Yeah. Both are upstream budgie issues.

I have never understood why upstream insist on having the screenshot keys under the solus dconf umbrella. It just causes confusion all round.

Screenshot issue has always been an upstream issue. Again,this needs more work to make the screenshot app work correctly under budgie

“Samedi 1 août” in your clock applet feels completely weird as well by the way. “1er” would look better.

It’s like saying “Saturday one August” in English.

Never paid much attention to that, but you’re right.

I don’t know if that clock can handle some « exceptions » as in English - if I remind correctly - any day number is always ordinal ( 1st of month, 2nd of, 3rd, 4th and so on ) so it’s not written because it’s always like this ( c’est sous-entendu quoi, donc pas besoin de l’écrire ) ?

French may need one graphical exception for the first day of the month, 1er ( premier, first ) instead of 1 ( un, one ), where er are superscript/exponent, in any clock ( not only in applet ).
All other day numbers are all cardinal.

It’s a digital clock, just like your phone. So I see on my phone Mon, 3 Aug

Each language has its rules.

Maybe English has an official digital dictionary.

Digital or not, french date format implies 1er as shortner for «premier / first », « un / one » is never told neither read neither written in a date.

And my ( android ) phone read Samedi 1er Août 2020, as expected.

think we need a french speaking dev to look at the code here and help craft the correct rules.

ah no worries - found the rules here https://stackoverflow.com/questions/13627308/add-st-nd-rd-and-th-ordinal-suffix-to-a-number

Raised this if anyone is interested in helping to implement https://github.com/UbuntuBudgie/budgie-extras/issues/351

In german it is much easier: After every number you have to set a point “.”, like Montag 3. August


having about nothing to do, I’ve tried to install Budgie Groovy on a brand new VM provided bu a 50 Gb virtual disk.
First, I’ve noticed that pressing spacebar is useless and that iso seems to start as it does for uefi systems, nevertheless I’ve left vdisk partition table in “msdos” mode and noticed that installer creates anyway a grub partition and a EFI one without asking. Then as soon as it arrives to grub installation, it fails to install it.
I’ve re-done the job creating on disk a gpt partition table but the song remains the same [quotation needed :wink: ]: as soon as it comes to grub installation, it fails.
I’ve chosen to use the whole disk … etc, so maybe is something depending on my choice, I’ll give a try from “other” choice and partition VD by hand (I’ll let you know how it will go) but I’m asking myself (and asking you): if “uefi-like” setup is now a standard, what about older PCs?


[EDIT]: I’ve tried partitioning VD by hand: it asks for a EFI partition, regardless of partition table. This means, if I’ve correctly understood, that 20.04 is last Ubuntu release allowed on non-uefi PCs? What a pity!

What date is your daily iso? Yesterdays iso has an important fix to allow grub installs on a legacy bios (non uefi)

I’ve downloaded it yesterday at 4:30 pm CET+DST (2:30 pm zulu time).
Now I’m going to lunch: I’ll start new iso download and let you know.


@ puffettacicciottella

What tool did you use to create the virtual machine? Did you set it to boot in UEFI mode or BIOS mode (alias CSM alias legacy mode)?

Please notice that the Groovy iso files boot via grub also in BIOS mode now.

no way: created msdos (legacy) partition table and empty disk (from gparted inside iso) but i get only what you can see in attached picture.
It starts anyway in efi mode; btw I’ve right now downloaded new iso from cdimages.ubuntu.com


Please report this issue via the live session … I.e.boot into the live session, attempt to install

Then run

ubuntu-bug ubiquity