Screenshot shortcuts not working (by default?)

On a clean 19.10 version, I tested the screenshot shortcuts (Settings>Devices>Keyboard) but the “Save an Area to Pictures” does not work, regardless of the shortcut assigned to it.

Worse, it seems whatever I do, I cannot change the behavior of the Print Scr button!

Default
Screenshot from 2020-03-13 09-21-32
In this default version:
Alt+Print works (screenshot of window to Pictures
Shift+Print does not work (screenshot of an area to Pictures)
Print works (screenshot to Pictures)

Now it gets weird when I switch up a few:
Screenshot from 2020-03-13 09-12-20
In this custom version:
Alt+Print works (screenshot of window)
Print does not work as expected (screenshot to Pictures INSTEAD of screenshot of an area to Pictures)
Shift+Ctrl+Print does NOT work (screenshot to Pictures)

No matter what I do, it seems “Print” button is ALWAYS generating a screenshot of my entire screen!

How do I fix this?
the only way I take a screenshot is by selecting an area…

1 Like

Upstream have in their wisdom hard-coded various print options to using gnome-screenshot. So there is no ability to change this without changing the code.

Also for a reason I’ve never really understood why it has not been implemented all of the screenshot key combinations

The code is here https://github.com/solus-project/budgie-desktop/blob/master/src/wm/wm.vala#L304

Its something that could be looked at for the 20.10 list of enhancements - assuming it is implemented we could then backport for 20.04 LTS users.

Unfortunately I am not a coder/developer at all… If I could I would definitely contribute. Hope someone else can help.

Not being able to select an area at all, is crazy in my opinion. Guess the only way for now is to find and install a 3rd party application?

You can run gnome screenshot from the menu and choose the area option. Alternatively you can use the budgie screenshot applet that has an option to grab by area.

Thanks, guess those are workarounds. But I would like to try to keep my Panel clean… I love the functionality that Budgie applets add, some of it is really essential like hotcorners and the screenshot applet. But I would love to be able to hide the icons and just activate the command the applet runs via a hotkey.

is there maybe a command I can run to activate the screenshot area selector?

Something like the command to show running apps /usr/lib/budgie-previews/previews_triggers hotcorners_all that is used by the hotcorners applet?

ok - found that budgie-desktop has defined three keyboard shortcuts for capturing screenshots

So “take-region-screenshot” is the area screenshot

budgie-desktop doesn’t take its cue from the keyboard settings shortcuts - its hidden away in dconf but totally not obvious to anyone but the serious tinkerer

Oh thanks for that! But how can one use that? I tried creating custom commands for keyboard with it no success.

But I also accidentally found out, regardless of whatever shortcuts are set, the following always works:

Ctrl + Print + Print

Just double click on the Print Scr button while holding down Ctrl. You will get the area selector! Perhaps that’s what triggers the Budgie command you mentioned?

1 Like

Just hoping you have a moment to explain how to use this as a non-linux expert?
I am still using CTRL+PRTSCR+PRTSCR+PRTSCR (hitting that button 2, 3 or 4 times will turn the cursor in an areaselector) but it will create 1 or 2 full screenshots before the area selector appears :frowning:

Hold [ ctrl ] and while holding it, hit [ printscreen ], this will turn the cursor into a + shape, meaning it waits for you to select your screen area with mouse holding its left button, and will save the picture once you release the mouse button…

It’s default behavior on my 19.10.

I’m noticing the same things. The shortcuts in the keyboard settings have no relation to what actually happens. Like Zilexa if have to press [ctrl] + [print] + [print] + … an arbitrary number of times before I get the area selector. In addition, the screenshot is saved to the pictures directory instead of going to the clipboard. Is there a way of directing this to the clipboard? I am currently using the screenshot applet but this is not convenient. I’m new to linux and am trying to learn.

I have already covered this on my March 13 post.

The TL;DR; upstream only supports 3 types of screenshot capabilities and they don’t use the keyboard settings values.

If you don’t like these you have to remove the keyboard values in dconf-editor … and Settings - Keyboard. Then define your own custom keyboard settings with appropriate command line entries

See gnome-screenshot --help for the parameters you can use.

2 Likes

Just fyi, even if I add a custom command with gnome-screenshot -a as command and CTRL+S as shortcut, it is highly dependent on the current focus whether the shortcut works or not.
For example, when the focus is on Budgie Desktop Settings window, it does not work. When I click on the desktop area, it works sometimes.

Also, it gives an error when using the command in terminal:

$ gnome-screenshot -a
** Message: 13:46:11.111: Unable to select area using GNOME Shell's builtin screenshot interface, resorting to fallback X11.

EDIT:
I had only disabled all screenshot related shortcuts in Keyboard settings and added my own custom command.
Installed dconf-editor, changed the screenshot shortcut to Ctrl Print and changed the area screenshot to ‘Print’. Removing my custom command from Keyboard settings.

Now, ‘Print’ button works as expected and regardless of window focus :smiley:
Only thing is I have to always hit the button twice quickly. Hitting it once: nothing happens. This is OK for me.

I have created a script to disable all non working screenshot shortcuts + switch gnome binding of PrintScr from full screen to area screenshot + mkdir Screenshots + change default location of screenshot files.

I’d say this should be default behaviour :innocent:


# Print Scr should take area screenshot + save to Pictures/Screenshots
# -------------------------------------------------
# disable related keyboard shortcuts since they don't work as expected
gsettings set org.gnome.settings-daemon.plugins.media-keys window-screenshot-clip '@as []'
gsettings set org.gnome.settings-daemon.plugins.media-keys area-screenshot-clip '@as []'
gsettings set org.gnome.settings-daemon.plugins.media-keys screenshot-clip '@as []'
gsettings set org.gnome.settings-daemon.plugins.media-keys screencast '@as []'
gsettings set org.gnome.settings-daemon.plugins.media-keys window-screenshot '@as []'
gsettings set org.gnome.settings-daemon.plugins.media-keys area-screenshot '@as []'
gsettings set org.gnome.settings-daemon.plugins.media-keys screenshot '@as []'
#switch PrintScr binding to area screenshot and its default to full screen 
gsettings set com.solus-project.budgie-wm take-region-screenshot "['Print']"
gsettings set com.solus-project.budgie-wm take-full-screenshot "['<Ctrl>Print']"
# change default folder
mkdir $HOME/Pictures/Screenshots
gsettings set org.gnome.gnome-screenshot auto-save-directory "$HOME/Pictures/Screenshots"
1 Like