Volume up-down, calculator, ctr-ALT T, windows key + A and more, not working

Media keys started working fine here, thank you.

I’ll have to test this on my install. My automation scripts auto apply the fix, so I currently have that enabled on my 19.04 machine.

I just experienced this issue :C, sorry but I read this post sequentially and did the workaround already :sweat_smile:

And just for clarification, did that work around solve the issue for now?

It worked after doing it, not a permanent fix.

Having the same issue of shortcuts not working (e.g. print screen, window switching) after latest sudo apt-get upgrade on my system, and confirming that the below command temporarily fixes it:

^^^ that is a better workaround if you dont need to use multiple keyboard layouts

thanks, disabling ibus seems to work. will keep an eye on this.

I defined a shortcut to shutdown my machine and then sometimes it worked and sometimes it didn’t. I wasn’t able to determine what causes it not to work.

settings -> region&language and there, click on “manage installed languages” then changed “keyboard input method system” to none instead of ibus. Logout and login.

finally did the trick.

Everyone - I have a tentative real fix for 19.10 users - I need people to test please and to let me know - good or not so good if this issue is finally fixed.

So please readd the IBUS keyboard input method (you will have set this to None) in settings -> region&language, click on “manage installed languages” then change “keyboard input method system” to ibus instead of none. Logout and login.

sudo add-apt-repository ppa:ubuntubudgie-dev/desktopkeygrab
sudo apt-get upgrade
reboot --

Since this is such an intermittent issue - you’ll need to do your regular routine’s - suspend/reboot - whatever you need to-do. Just check regularly if shortcut’s and media keys stop working.

To remove the PPA:

sudo ppa-purge ppa:ubuntubudgie-dev/desktopkeygrab
reboot --


1 Like

Continuing the discussion from Volume up-down, calculator, ctr-ALTl T, windows key +A and more, not working anymore:

Hi all,

I am a new Linux user in general and am experiencing this issue as well. I installed Budgie 18.04.3 a few days ago and updated with apt update apt upgrade.
Here are some of my symptoms, if they are of any help:
Screen brightness media keys (F11 and F12) work without pressing Fn key. Pressing Fn+F12 opens a terminal with max horizontal width snapped to the top of the screen.

I use Bulgarian input as well, but not sure if I need iBus input method system.
Switching to ‘none’ with logout/login does nothing for me. nohup budgie-wm --replace & fixed the default shortcuts for launching Tilix and Nautilus, but didn’t help for the media keys.
I will do some more attempts with the workarounds and see if there are any results.

Hi and welcome,

this issue is very specifically about keyboard shortcuts that seemingly disppear after a logon - but reappear on another login.

So your observations are perhaps another issue. F12 is a mapped customer keyboard shortcut to open tilix in quake mode. The fact that Fn is/isn’t required is odd but I’m guessing is an issue with your keyboard hardware not being correctly recognised. Suggest raise this a bug-report to launchpad by typing the following in a terminal.

ubuntu-bug linux

I’m just getting around to this - just reenabled ibus and put the test PPA on.

Try without the plank dock. It’s peculiar, but when I switched away from Plank and to an autohide panel, this issue, for me, went away…
Can Plank be interfering?
My issue was that randomly, on logins, some keyboard shortcuts (I recall Alt Tab, Calculator, Tilix Quake Mode, Volume Keys, Super A to launch Raven) didn’t work. I logged out and in, worked. Completely random. @fossfreedom will your PPA help here?

hopefully yes.

The proposed fix is also in 20.04 proper (no PPA required) - this also has budgie desktop 10.5.1 as well.

1 Like

I still have this problem. I installed Ubuntu Budgie 20.04 a few days ago and set the print screen key to launch Flameshot. Right after I did that, it worked fine. However, every time I reboot, pressing print screen behaves like the default (saving a screenshot of the whole screen to pictures). I tried disabling IBus and it didn’t work. nohup budgie-wm --replace & didn’t work either. Do you have any other solutions?

Yours is a totally different issue

You need to disable print screen in two different places for a custom keyboard print screen to work

Thank you so much :smile: it worked for me

Well maybe three different places → Testing 20.10 - only for the most adventurous :
⋅ Parameters/Keyboards.

I am using ThinkPad T440p, and fn-escape toggles FnLk, so I can now use F-keys as normal (haven’t restarted yet, so don’t know if setting sticks, I will restart and check now).