Volume up-down, calculator, ctr-ALT T, windows key + A and more, not working

Several keyboards keys, combinations of key do not work anymore ( UB 17.10 )

Any ideas why they could have stop working ? Ubuntu or budgie problem on my side ?

I applied all the updates Ubuntu or budgie updates.

Can you describe which ones? Liking for a pattern. Thank you…

I can confirm I’m experiencing the same bug in my (cleanroom) gnome builds, using the same custom shortcut management script (and at least some of the same shortcut keybindings)…

An interesting thing to note, is:

  • Settings -> Devices -> Keyboard is listing the correct key combinations in the custom shortcuts area
  • if I try to re-bind the same shortcuts, Alt and Win (Super) are not registering as keys in the mapping dialog. Nothing happens when you press them…

This is only applicable to updates from the last 24 hours, unfortunately I’ve prematurely purged my previous builds due to space limitations so I can’t do a filter on the changes :frowning:

ok my mistake… some still work but I’Ll tell you some of the ones that stopped functionning was using that do not…

CTRL+ALT + T : Terminal
Keyboard Volume up, down mute
Caluculator key

Those ones I used them often and they are not working… Since when ? SUppose one of the last updates…

SUPER Key A and N are working ( my TOPIC subject is wrong mentionning SUPER + A

That is interesting. Super Key A and N are budgie-desktop specific keycontrols handled by budgie-desktop itself.

CTRL+ALT+T is handled by GNOME - gnome-settings-daemon - so sounds like a bug needs to be reported on that package.

Keyboard volume Up and down and Calculator key - not sure - possibly kernel related or possibly again gnome-settings-daemon.

1 Like

Where should I support that ?
Here ?



Also on launchpad via running this in a terminal

ubuntu-bug gnome-settings-daemon
1 Like

ok after following this

sudo apt install compizconfig-settings-manager
sudo dpkg-reconfigure gdm

Problem was still there… After RESTARTING problem went away…

Is it the restart ? or the article above + restart that fixed it ? I will never know, but I am ok now


I am doubful any of that actually did anything. The problem sounds more random and by virtue of rebooting a few times the problem went away.

ccsm is compiz and does nothing by itself.

Gdm is more interesting here. You have changed the login manager.

Anyway. Please keep monitoring and let us know when the issue reappears. Cheers.

1 Like

I don’t know if I would mark a restart as the solution (IMHO). This is more directed to whoever marked it as so. :slight_smile:

I have also reported a bug. If we as a collective want to add more info to the same bug report, here is the link. https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1759462


I not only install csm… They were talking about the plugin “Commands”
It was not, but I turn it on, then off, then restarted

But it’s probably more the Restart that did something as you said…But I wanted to be more precise on what I did

I will report too the problem, tks for the suggestion !

Another test I just completed. In a situation where my shortcuts were working… I put caffeine on to prevent sleep or hibernation… and my shortcuts are still working. Granted I was not doing a lot on the machine over this time… Used it for a bit and then went to bed. But 8 hrs later. still good. I’m going to work shortly and I might try to leave my laptop running for my commute and then use the machine through the day with caffeine on. See how it goes.

EDIT - 15 hrs later - keyboard still functioning as expected with caffeine on.

1 Like

hmm - so do we think this is a suspend/resume issue - or do we think this is a screenlock issue?

About 15 minutes ago I suspended my machine intentionally. I’ll wake it up shortly and try.

Ok - after wake up from both hibernate and suspend… still worked. then I shut down and took my machine home… upon reboot 3 hrs later - the shortcuts were not functional.

interesting. Ok we need to continually narrow this down.

Remind me - how many times do we have to reboot before shortcuts begin to work again?

Lets try to remove each component to see if the problem reoccurs.

First suggestion to progress: Don’t use hibernate - always use suspend. We already know linux has difficulties with hibernate, so lets take that out of the equation.

When testing with a lengthy suspension followed by a reboot - lets take the lock screen (gnome-screensaver) out of the equation - i.e. in power management turn off autolocking. To turn off the lockscreen on resume

gsettings set org.gnome.desktop.screensaver ubuntu-lock-on-suspend 'false'

Thus this is more like the caffeine scenario -we dont allow the computer to autolock the screen.

I’ll keep troubleshooting. It’s been working over the last 24hrs. Monitoring. Maybe an update?

Same issue here on both 17.10 and 18.04.

Additional Info:

I just found out another detail quite by accident.

My system is set up to use the “fn” key to make the F buttons behave as an f button (F1-12). Meaning by default a press will trigger the volume up/down, etc.

So when the audio keys conk out… my other f key functions (brightness, etc) still work. BUT, if I hold “alt”, and press my audio keys - they work!

Now knowing this pattern, - I went through my F keys… and tested what worked (brightness, audio, mute, search)

  • F1 (mute) - “F1” works with the “fn” key, and the mute only works when also pressing “alt”
  • F2 (vol down) - “F2” works with the “fn” key, and the vol down only works when also pressing “alt”
  • F3 (vol up) - “F3” works with the “fn” key, and the vol up only works when also pressing “alt”
  • F4 (disable mic) - Works as expected.
  • F5 (bright down) - Works as expected.
  • F6 (bright up) - Works as expected.
  • F7 (projector) - Untested.
  • F8 (airplane mode) - Works as expected.
  • F9 (tools) - Does not work in any capacity
  • F10 (Search) - “F10” works with the “fn” key, and the search only works when also pressing “alt”
  • F11 (launchA) - Works as expected.
  • F12 (open file browser) - Works as expected.

Also opened a bug direct with gnome.