Testing 21.04 - are you brave enough?

And again no wobbly animation or magic lamp. Still, if I chose cupertino layout would be nice if both of this effects be there.
I think there is nothing bad in those little fancy effects. Last couple of weeks I spent on Fedora (on VM) doing my boring job and those little things brings me almost happines :slight_smile: You should try them on Gnome.

I remember those effects from the compiz days year ago. Didn’t like them then …

If those animations appear on UB the rank of UB on distrowatch will soar up at least few positions. Mark my words :slight_smile: And give them a chance.

On VM 21.04 starts and runs nice and smooth. ZSH with encryption, nautilus instead of nemo, calendar instead of clock, mojave theme, budgie layout, global menu, everything looks good. Still geary in apps, but also thunderbird. Quite big consumption of memory.
Very good job, guys, thank you and congrats.

That’s an odd observation about Geary. Will need to find out which package is installing it I.e. has Geary in its recommendations or dependencies

Tested a bit in a VM, saw no major issue, so I decided to guinea pig myself. If I want to help catch some bugs early on, gotta run it on hardware, in my production machine, which is also running JACK via ubuntu studio goodies. What can possibly go wrong?
Took a clonezilla to a separate SSD, did a release upgrade, and configured timeshift to run multiple times a day, just in case.

So far so good, no issues, system runs super fast and smooth. Well done team, looks like this is going to be another solid release! :star_struck:

1 Like

I have been using Ubuntu Budgie 21.04 as my daily driver for some days now, and I started to find some minor issues here and there. Would it be valuable to start reporting now or is it better to wait until beta is out? In case you want me and other testers to report those, could you kindly link to the correct bug trackers?

Few examples of the issues I found:

  • gnome-software does not start from the gui. I click on the icon, I see a loading icon indicator, and then nothing happens. If I start it from the terminal though, it works fine.
  • scanning documents with my HP printer, which is correctly installed with hplip, does not work. I start the scanner, software asks me which printer to use, it finds the correct printer. Once I select it, administrator password is asked and then an error displays fail to connect to printer. Same thing works fine on 20.04 and 20.10.

Thanks for your help!

Both issues I would just keep an eye on for now. Things are being pushed through debian pretty fast at the moment trying to beat the upcoming February freeze date.

At that point just bug fixes will be coming down the software line. So by late February I would start reporting issues to launchpad if they are still broken.

1 Like

I am using the 21.04 in my daily work with no issues as we speak.
I bought an new computer recently dedicated for my work and as a Plex server after work.
Since installation of the 20.10 version did not get the Realtek network Ethernet to work, I got the idea from internet that the newer kernel supported it.
I got the same trouble with 21.04, but managed to install a r8125 driver with help from a slow USB network dongle.

So now I am up and running and really like to work on a Linux computer vs my old MS10. Last time I played with Linux was in 1997. Then as now, the network card was my challenge.

My Plex server is gone down for the moment for some reason, but think I will let it be for a later reinstall when the system is more stable.

I do wonder if it is wise to do update every day as long as the system works with no issues.
My fear is that a update corrupts something vital, and that I can not start up the system again.
Any advice here would be great.

Obviously you have read my first post … please don’t put this on a production machine especially if you are depending on something critical working.

That said, with regards with your realtek ethernet - kernel 5.10 has just entered proposed and should pop into main soonish - maybe your realtk will work out of the box - maybe not.

Some people swear by “timeshift” - so it makes a snapshot of your system before you update. So do use a good fast second drive when using timeshift.

Other than that - you should really write documents etc onto a second drive - somewhere you can access quickly if you have to reinstall.

Yes, I am aware of the risks using a system before release, So I am not storing any work documents local on my machine. All my work is at Sharepoint, so only download local if I need to do something in Calc.
Upload back to Sharepoint when Finnish the document.

Think I have the 5.10 Kernel on my system now fore some days. It did not let my Realtek r8125 work automatically either. But an manual install of the driver fixed it, and are working for now.

Still wondering if it is more secure/stable to do updates once a week or every morning.

At this early stage - no real difference other than using bandwidth and your time spent updating

1 Like

May be a good idea to keep a copy of the driver locally (on a usb etc.), so future installs are easier

Yeah. I think I am safe with the cheap USB ethernet that I bought. Seems like this Will work. Found a recipe for install of the r8125 that worked superb. But I Will follow your suggestion and save the link for the procedure a safe place.
Hopefully Will the system be more stable soon. I plan to stick with the 21.04 for a while. Could be that I loose the driver again if the kernel gets another update. Think I am at 5.10 now.

Run in a terminal

uname -a

That will tell you what kernel you are booting with


I am at: 5.10.0-12-generic #13-Ubuntu SMP Mon Jan 11 22:44:11 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Hmm. How did you manage to install that?

It hasn’t passed testing yet and as such is in the proposed repo.

Are you running with the proposed repo enabled in software sources - developer tab?

If its ticked I would strongly urge you to untick that. Proposed can and does have broken packages.

Yes, this was ticked, but not by me.

Have unticked it now.

It seems you were right.

Both the issues described above are now fixed: I can open my software center just fine now, and my HP printer asked me to update the HP plugin, downloaded it automatically, and now scanner works flawlessly.

1 Like

Have spent some time with 21.04 in a VM (yes, I’m not brave enough). I was wondering, if there is any outline of testing areas or whether testing is unstructured/random. I’m asking this, because I found some problems with snaps and end up with the impression, that snaps are not well tested, f.i.:

  • Epiphany crashes when opening Preferences (problem in config of org.gtk.Settings.FileChooser)
  • Firefox not opening file chooser for certificate import (when installed as snap)
    So is snap a reasonable approach forward or is it to be avoided?