The keyboard layout switches too long

I upgraded Budgie to 22.04.
When i press Super+Pause, the keyboard layout changes, but too long. 1.5-2 sec.
I use Budgie Control Centre and ibus-setup, to configure keyboard layout switch.
This was not before.
How can i reset and fix the settings, to the layout switches quickly?
Removing the keyboard layouts does not help. I think I need to reinstall.

The normal keyboard layout key combination is Super + Space / Alt + Left Shift. How have you managed to change to Super + Pause?

What happens with Super + Space and / or Alt + Left Shift ?

oh, no. I have Super + Space keyboard layout key combination.
when i wrote Super+Pause, i made mistake.

I have all default.
I deleted the layouts. I add them… the keyboard layout changes, but too long.

I need simple decision.
Example: “you should delete or purge that package and you need reinstall it” :slight_smile:

please create another user account and test there. Lets see if its a per account issue or a system wide issue.

yes, it`s good idea. i already do that. Another user has the keyboard layout changes too long

So what keyboard layouts are you using?

i use en(us),ru keyboard layouts

what ibus packages did you install for the ru layout?

i dont known. I add russian language by Budgie Control Centre → keyboard - input sourses

what ibus-setup configuration options did you choose?

it`s now:
ibus-setup configuration options


ibus-setup configuration options



ibus-setup configuration options



❯ ibus read-config

SCHEMA: org.freedesktop.ibus
SCHEMA: org.freedesktop.ibus.general
  enable-by-default: false
  xkb-latin-layouts: ['ara', 'bg', 'cz', 'dev', 'gr', 'gur', 'in', 'jp(kana)', 'mal', 'mkd', 'ru', 'ua']
  use-xmodmap: true
  preload-engines: @as []
  dconf-preserve-name-prefixes: ['/desktop/ibus/engine/pinyin', '/desktop/ibus/engine/bopomofo', '/desktop/ibus/engine/hangul']
  use-global-engine: false
  engines-order: ['xkb:us::eng', 'xkb:gb::eng']
  embed-preedit-text: false
  switcher-delay-time: 400
  use-system-keyboard-layout: false
  version: '1.5.26'
SCHEMA: org.freedesktop.ibus.general.hotkey
  previous-engine: @as []
  enable-unconditional: @as []
  disable-unconditional: @as []
  next-engine: ['Alt+Shift_L']
  trigger: ['Control+space', 'Zenkaku_Hankaku', 'Alt+Kanji', 'Alt+grave', 'Hangul', 'Alt+Release+Alt_R']
  next-engine-in-menu: ['Alt+Shift_L']
  prev-engine: @as []
  triggers: @as []
SCHEMA: org.freedesktop.ibus.panel
  show: 0
  show-im-name: false
  y: -1
  use-glyph-from-engine-lang: false
  show-icon-on-systray: false
  auto-hide-timeout: 10000
  lookup-table-orientation: 1
  custom-font: 'Sans 10'
  xkb-icon-rgba: '#51a2da'
  use-custom-font: false
  property-icon-delay-time: 500
  follow-input-cursor-when-always-shown: false
  x: -1
SCHEMA: org.freedesktop.ibus.panel.emoji
  has-partial-match: false
  favorite-annotations: @as []
  load-unicode-at-startup: false
  partial-match-length: 3
  favorites: @as []
  hotkey: @as []
  lang: 'en'
  font: 'Monospace 16'
  load-emoji-at-startup: true
  unicode-hotkey: @as []
  partial-match-condition: 0

1 Like
❯ setxkbmap -query
rules:      evdev
model:      pc105
layout:     us
options:    terminate:ctrl_alt_bksp

here how it looks:



What can i do more, to adjust a long change of the keyboard layout?

I’ll try to look at reproducing this in the next few days (hopefully)

I’ll be very grateful. I can use it, but it a little hard…

May be, is there some simple way, to overcame it?
purge it… reinstall that?

I think this is some kind of rare interaction of some two subsystems (ibus and some other, I do not know). As I understand it, I tried to configure the standard, as you say, switching using the Alt+Shift.

It turned out that when you press the alt+shift, windows are closed (for example, you can’t switch the layout in the search field in the analogue of the Start button using the Alt+Shift. I decided to return the super+space and something broke.

don’t know what your issue off the top of my head. You shouldn’t need to define the short-cut key within ibus-setup to switch layouts - that is something budgie-desktop expects to-do for you - Alt+Shift and super+space are shortcut-keys managed by budgie-desktop.