Turn off notifications

Just found out that turning off notification in 19.04 for a specific application can be achieved in Settings > Applications > <Srollling the left panel to the desired app and click on it (VLC-Player, in my case) > Notifications OFF.

This at least avoids the annoying pop-ups every 3 minutes.

That is very interesting. I wonder how that list is filled? Would be nice to also hide printing notifications via that list

EDIT: so any application.desktop file in /usr/share/applications that has “X-GNOME-UsesNotifications=true” will appear in that list

"EDIT: so any application.desktop file in /usr/share/applications that has “X-GNOME-UsesNotifications=true” will appear in that list "

Cool to know …

There is a printer app in my list … I just don’t have a printer to check if the notifications pop up …

On 18.10 added “X-GNOME-UsesNotifications=true” to the two printer apps in /usr/share/applications, then reboot. Turned off printers in the Notifications, no change :frowning: Same thing on 19.04.

ok - on 19.04 - I opened Settings - then Applications - chose Printers - and turned off notifications. i.e. I ignored Settings - Notifications - …

I printed - no popup notifications was visible - raven notifications still recorded that a notification happened - so that sounds like good news to me.

Your steps are different than I followed, will thy them.

chose Printers - and turned off notifications
I am probably dense but I see no option after choosing Printers to turn off notifications.

image

OK, seems to work. Hope the gnome folks do not “fix” something make this not work.

1 Like