Home Store Blog Development

Turn off notifications


#1

Ubuntu Budgie 18.04 with HP printer installed (hplib). Is there any way to turn off printer notifications, have all notifications turned off but still get printer popups.

Thanks


#2

Configurable notifications is something not currently available in budgie.

There is a very recent commit upstream that allows you to turn off all visible notifications - but that has not yet been formally released by upstream.

This is probably an area we may look at for the next development cycle. If anything in this area is formally released, we will look to see if it is suitable to backport as a microrelease for the 18.04 LTS.


#3

Thank you David. FWIW, I stopped looking at ubuntu bodgie at 17.04. IMHO, it just had too many problems to be used as a daily driver. Well, 18.04 is a big improvement. I now have it on one of my systems used daily. The only gotcha I have found to date is that notification popup. Backporting is would be nice :slight_smile:


#4

Google around and check online. If it’s based off the Gnome notifications, there may be some config or other files you can alter, but don’t take that to the bank… If it’s not, then never mind… :slight_smile:


#5

Boy this printer popup is annoying. I suspect its hard coded in the Bodgie WM. Seems like it should be turned off by default since you get the same thing in the Notifications applet. Such glaring problem for an otherwise very solid release.


#6

@makitso this works? https://askubuntu.com/questions/918462/ubuntu-17-04-printer-added-notifications-under-gnome


#7

I am sorry to say that it did not work. Nor did sudo systemctl isable cups-browsed.service have any impact.


#8

I’d love to see this in a future release.


#9

We’ll make it a priority to see what is possible.

If anyone wants to help out then we can make this available to all budgie desktop users sooner rather than later. Please shout if you are interested and we will try to get you going on compiling eta budgie desktop


#10

Every time I receive a popup, my Game starts lagging, until the popup goes away. It would really be great if I could just disable popup notifications permanently, forever.

Playing a sound is plenty of information for me :slight_smile:


#11

You can turn off pop ups in 18.10. There is a button in raven on the notification panel.

We will be looking to create a test ppa for the same version of budgie desktop in 18.10 for 18.04. We will need to fix a few things before asking for more help testing it.


#12

Thanks! I’m assuming you’re talking about this little bell right? https://0x0.st/s6Im.png

Problem is, it turns itself back on when I restart the computer.


#13

Yes - its that one. I did ask the upstream solus project if we could make that permanent. They did not want that to happen - it is a per session setting.


#14

Ah, I see. Thanks a ton!


#15

. They did not want that to happen - it is a per session setting.

That’s unfortunate. FWIW, Elementary OS makes it permanent. It probably is a different set of priorities, UB is more user-friendly whereas Solus appears to be focused more on seasoned Linux users.


#16

May be we can somehow persuade upstream to be reopen the idea. I am more than willing to supply a patch depending upon how upstream would prefer to implement it.