Ubuntu Budgie 22.04 Terminal

has anyone any idea on why in a terminal this runs this after most commands ?

bash -c 'sleep 5 && /usr/share/budgie-desktop/gdmcheck/gdmcheck.sh'

not to worried about it just wondered why it’s happening

It should only be run on logon budgie-desktop-environment/10-budgie-desktop.sh at master · UbuntuBudgie/budgie-desktop-environment · GitHub - this is a prompt to say “don’t run budgie with gdm3” because it will break stuff like locking the screen.

I’m not running that script it just runs randomly on termination of a terminal command for example if I ran sudo apt autoremove
that line of text may or may not appear after the command has completed. I do use tmux inside the terminal perhaps that has some bearing

Hmm… i am not familiar with tmux. I am not sure why any /etc/profile.d script will be repeatedly run other than at login .

This another thought I have both budgie & ubuntu desktops installed … I have not used the ubuntu desktop since installing it but could that have altered something ? The initial install was done via budgie & not stock Ubuntu & I added their desktop after install

I would do a fresh install … dont mix desktops … especially installing gnome-shell since it breaks budgie.

used to work fine in 20.04 but I’ll do a reinstall … however /home is on another drive, for the reason if the OS goes wrong I don’t loose data. That said would there be any thing written to /home that I need to remove ?

The only areas budgie, welcome and our budgie extras writes to specifically in the users home folder is



/home is not an agnostic place. All the hidden data in each $HOME ( = /home/$USER ) are OS and software version dependent.

Something like ~/.config/dconf is used by many many many app’s to store settings, including settings peculiar to a Desktop Environment…

…and this is exactly where problems start to begin : when you have 2 DE ( launched by same $USER ) they will every now and then write their different config’s into the same files. What’s good for one may not be good for the other.

Many DE are more or less forked from Gnome. All these share deep and ancient « root » that make them almost impossible to live under one same $HOME ( Budgie, Mate, Ubuntu just can’t live together well under the same roof of one $USER ).

If you want to play with many DE, at least dedicate one specific user for each of them, that will keep you safe from most config’ mismatches. Not all, because each ×buntu variant also includes its own implementation of system components ( graphical session manager, lockscreen, plymouth, gdm, lightdm… )

Since the content of your /home folder is on a separate drive, I’d also advice :
⋅ from your older $USER folder, remove all hidden content ( keep that hidden content elsewhere ),
⋅ only keep in that $USER folder the visible data ( Desktop, Documents, Pictures, Music, and so on )
⋅ fresh reinstall with same name for $USER ( given there was only one user, )
⋅ mount the content of your separate drive into /home folder during installation,
⋅ this will repopulate your /home/$USER folder with the expected hidden elements matching your new OS ( and all its app’s and software, including DE. )

Once there, check everything’s works fine, everything is anew, untainted, out of the box.
And later, import from your older hidden personal data you kept elsewhere,
only the « interesting » parts : « profiles » for your favorite app’s ( things like .mozilla, .thunderbird, ~/.config/GIMP, ~/config/libreoffice and so on ).

⋅ many DE under only one /home/$USER is always a bad idea,
⋅ the idea of a separate /home partition is far from being bulletproof as hidden specific data are tied to an OS at a given time.

I blame the hardware manufacturer for this to a degree, the machine shipped with a 128gb ssd boot drive & 1tb sata data drive. if you leave /home on the boot drive and install steam & few games the boot drive is filled in no time !

purchased a new ssd (1 tb),re Installed with a new home folder on the new drive … guess what no change, apart from the screen no longer blanks out

Don’t use the folder /home as a mounting point, just let it be the expected folder at the root system tree on your SSD.

This way
⋅ a whole unaltered system sits on the 128GB SSD
hidden personal data in your $HOME will benefit from its speed.

Use ( one of ) your 1TB drive as a secondary storage, automatically mounted at boot for
⋅ your visible ( agnostic ) data ( documents and media )
⋅ some of the « heaviest » hidden data you might chose to move and symlink from $HOME to that 1TB drive.

Mount the partition of that 1TB drive in /media/DATA by adding a line into /etc/fstab
Organize wisely your personal ( and mostly visible ) data on that big disk.
Move from /home/$USER/… your visible personal data and store them into your 1TB ( if not already done. )

1⋅ create the DATA_01 mounting point folder which will receive the data from one of your 1TB drive

sudo mkdir /media/DATA_01

2⋅ use it for mounting the 1TB drive by modifying your /etc/fstab file

⋅ First let’s do a backup of your actual fstab

sudo cp /etc/fstab /etc/fstab_backup

⋅ the lines to add at the end of your fstab
Use from terminal gedit admin:///etc/fstab or sudo nano /etc/fstab to edit this file.

UUID=<uuid_of_the_aimed_partition>	/media/DATA_01	ext4	defaults	0	2

⋅ While there, remove ( or comment ) any line that mentions /home as mounting point.
Reboot for applying.

3⋅ if your 1TB drive already contains your ancient $HOME folders’ structure then you just need to add a trash folder at its root for your user ( one is needed at the root of each partition, for each user ).

sudo mkdir /media/DATA_01/.Trash-$UID
sudo chown $USER: /media/DATA_01/.Trash-$UID
chmod 700 /media/DATA_01/.Trash-$UID

4⋅ if your 1TB drive already contains your ancient $HOME folders’ structure and if on your 128GB SSD your actual /home/$USER/{Desktop,Documents,Music,and,so,on} are empty then replace them with symlinks targeting the data stored in the 1TB drive.

⋅ removing the empty folders


⋅ replacing them with symlinks

ln -s /media/DATA_01/$USER/{Desktop,Download,Templates,Public,Documents,Music,Pictures,Videos} /home/$USER/

…beware the last / at the end of the line is very important.
…check the names of targeted folders twice ( English is not my language, maybe it’s Downloads and not Download, or Publicshare and not Public ).

What did we do there ?
Now from your $HOME in other words your usual personal folder
⋅ anything used through the symlinks {Desktop,Documents,Music,and,so,on} is actually stored in your 1TB drive mounted at boot in /media/DATA_01
⋅ any other thing outside the symlinks is actually stored in your 128GB SSD
⋅ you now have the ability to chose amongst your personal data what to store in your 128GB SSD or your 1TB drive.

To go further and optimize, you may want to move other « heavy » elements ( hidden or visible ) from your $HOME to /media/DATA_01/$USER and symlink them

⋅ move an hidden heavy folder called my_big_thing

mv ~/.my_big_thing /media/DATA_01/$USER/

⋅ replace the moved folder by a symlink to its actual location

ln -s /media/DATA_01/$USER/my_big_thing ~/

Symlinks are special files that act as the targeted elements.
Deleting a symlink does not delete the target.
Moving or deleting the target of a symlink breaks the symlink ( but link itself stays in place ).
Restoring the target fixes the symlink.

If you’re not comfortable with command lines, Nemo files explorer lets you create symlinks
⋅ right click on an element and « create a link » or
⋅ select an element and [ Ctrl ] + [ M ] or
⋅ drag and drop selected element(s) while pressing [ Shift ] + [ Ctrl ] between two open windows…

Beware the « if » - I gave an example while being blind about your actual situation.
Here I supposed your 1TB drive already contains data that were previously mounted in a /home folder.
If your 1TB is empty, there would be other things to check and organize first ( partition, ext4 filesystem, create a main personal folder + a trash folder ).

Other useful commands you might need

lsblk -fe7 -o +size

from a wide terminal window as the answer is a large table,
to have a view on your disks and partition, their names, uuid, mountpoints and so on.

cat /etc/fstab

to see the content of the fstab file.

A semi graphical tool to help spotting heavy elements :


which is unfortunately not installed by default

sudo apt install ncdu

I replaced the 128gb ssd with a 1tb ssd installed UB on that the data drive is not even mounted now so I am totally stock and it still does it, you did not quite see that in my last post

Then mount accordingly that data drive…
…you have to tell your system what to do with that drive, it can’t decide for you.

Please issue :

lsblk -fe7 -o +size

↑ from a wide terminal window as the answer is a large table,


cat /etc/fstab

here we go

NAME        FSTYPE FSVER LABEL   UUID                                 FSAVAIL FSUSE% MOUNTPOINTS   SIZE
sda                                                                                              931.5G
└─sda1      ext4   1.0           a9ca793f-2d05-42bf-805b-b09ed855d147                            931.5G
sdb                                                                                              931.5G
└─sdb1      ntfs         Back Up 34604DAF026F6336                                                931.5G
sdc                                                                                               29.7G
└─sdc1      exfat  1.0           9CE0-E0CE                                                        29.7G
nvme0n1                                                                                          931.5G
├─nvme0n1p1                                                                                          1M
├─nvme0n1p2 vfat   FAT32         3EEB-CDC8                             506.7M     1% /boot/efi     513M
└─nvme0n1p3 ext4   1.0           d1f9cfc8-ac28-447b-bf07-df8489b27131  655.7G    23% /             931G


# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p3 during installation
UUID=d1f9cfc8-ac28-447b-bf07-df8489b27131 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p2 during installation
UUID=3EEB-CDC8  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

i can confirm that the message is something to-do with tmux - easily reproducible when I run tmux inside tilix and then run an update

As I said - I have no idea what tmux is - or how to configure it. Why it runs /etc/profile.d commands is interesting - seems excessive

Note: when I run:

ps -ef | grep gdm

I see

dad         3835    3825  0 17:29 ?        00:00:00 [gdmcheck.sh] <defunct>

dunno why that happens - certainly an area to concentrate when looking at /etc/profile.d/10-budgie-desktop.sh

tmux is a terminal multiplexer tool in Linux. Essentially, it allows us to create and maintain multiple pseudo-terminal instances. Concretely, it maintains these pseudo terminals through a server process that’s started whenever a tmux command is executed.

Because these terminal processes are maintained by a server process, tmux provides us the flexibility to detach from any terminal session without killing them. Furthermore, we can reattach any of the terminal sessions at a later time to regain control. This makes it ideal for any long-running process that we can run in the background and reattach to regain control once in a while.

None of your 1TB disks are mounted at start - they are not described in fstab.

None of your 1TB disks are actually mounted - they have no mountpoint listed in lsblk.

Now if you would click in Nemo / devices on one of them they would mount in
…treated somehow like external storage. That’s not what you want I think.

Why NTFS for one of those disks ( labeled Back Up ) ? Do you have a Windows OS running somewhere ? Linux can read and write on NTFS but can’t fix/repair/maintain such a filesystem.
If you’re in a 100% Linux context, you should « re format » this drive to ext4 to avoid problems in the long run.

So now read again the long recipe / answer I made earlier.

Create a mounting point folder DATA_01 in /media/…

Adapt the line to add to your fstab :

UUID=a9ca793f-2d05-42bf-805b-b09ed855d147	/media/DATA_01	ext4	defaults	0	2

…this will mount the ext4 1TB at ( next ) boot.

Just do that for the moment. And see how it works.
You’ll find DATA_01 in the left panel of Nemo after a reboot.

A bit out of topic maybe : what’s your actual use-case for a terminal multiplexer ?

the ntfs disk is a data transfer disk that happened to be connected at the time of test
as I pointed out I have not mounted the drive containing the original ‘home’ data
I replaced the original 128gb with a 1tb disk, which is mounted.
tmux allows
this allows me to have loads of processes running