USB automount not working


The title says it all: automount doesn’t occur on 19.10 when I plug in a USB drive.

The corresponding Nemo setting (edit, preferences, behavior, media handling) is toggled on.

With dconf-editor, I’ve checked under that automount and automount-open are toggled on, and they are.

So… what to do?

Thanks in advance

yeah - there has been previous reports when using nautilus way back in the UB 17.x days.

So I’m interested in someone solving this as well.

Alright, thanks for replying.

As a workaround, it is possible to use the Drop By applet to quickly mount/unmount removable media. That said, the pop-up window always appears in the bottom-right corner of the screen (due to the position of the panel in Solus I guess?), even when the panel is in top position. Odd.

That observation is by design.

1 Like

It should preferably appear where the default notification position is IMO. This would allow for more consistency.

I disagree. This isn’t a notification and doesnt behave like one. Adding it to the notification area will cause confusion as to why windows behave differently.

Ah I see. However is it possible to configure the applet?
It kinda looks weird when it just pops out at the bottom.

No. No configuration options have been built into the current applet.

Indeed, in most desktops it is common behavior for USB notifications to show in/near the notification area, not on the opposite side of the screen. Or for clicks on panel applets to open something next to their position in the panel.

By the way, automount didn’t work either on a Solus Budgie 4.1 live OS. So, that looks like an upstream issue :frowning:

A post was split to a new topic: Xiaomi Redmi phone not visible

does this help?

Unless I’m mistaken, resorting to Gnome Disks in this way only solves the problem on a case-by-case basis. That’s what I’d do to auto-mount a storage partition on an internal drive. However, that won’t help with removable media in general: you need the device to already be there before setting it to auto-mount.

Non-technical users would still wonder why the USB key they have just plugged in does not “work” right away, even though it should according to Gnome Settings and Nemo.

Anyway, opening Nemo and clicking on the device’s icon in the side panel is usually enough to mount the device. However, I think it’d be great for newbies if their removable media just showed right away on the desktop (assuming desktop icons are set to display mounted devices, of course). You wouldn’t want them to use Gnome Disks and set auto-mount up every time they get their hands on a new USB key.

Agree with what you said. Look forward to someone working out the solution.

Automount for removable medias is also broken in Budgie 18.04 LTS. regarding snap & automount for the legacy way