Home Store Blog Development

Weathershow crashing on manjaro


#1

The Manjaro Budgie Maintainer finally dropped your changes into our stable build. I saw the Budgie-extras package and another Budgie package listed for upgrade.

After applying the update, the taskbar was a mess, lost most of my applets and had a hard time rebooting without the user indicator (had to pull up a terminal to reboot.) I rebooted and replied a reset;

nohup budgie-panel --reset --replace&

That worked, after I added back my applets. However, the one applet I LOVE, Weathershow, caused the taskbar to crash when adding. I even rebooted and tried to apply it again, and no show.

Is there an issue with Weathershow?

BTW, another Manjaro Budgie user got this after the update; eea451aa938fff96ee6dcc601649a6edbc152919

I told them to apply the update above. Will report back if it doesn’t work.


#2

Weathershow works fine on ubuntu and locally on my compiled debian buster system.

I am guessing here that there maybe a dependency issue.

Run

budgie-panel --replace &

Then add weathershow to your panel. What errors do you see in the terminal?

As to the pictures, never seen that. What applets are those white blobs corresponding to ?

What was that other budgie update?

Scrambled applet positions are as you know a weird occasional issue after a reboot. Hard to fix unless you first see the issue and then have the ability to dig into the budgie desktop panel code to find out why it is occuring


#3

Woops…you split the thread. Ha. Here is what I got as soon as I typed your entry into terminal. The last line is when I added Weathershow which crashed my taskbar and now I have to reboot.

(budgie-panel:27033): Gtk-WARNING **: 00:21:43.760: Theme directory actions32@2x of theme breeze-dark has no size field

/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:42: DeprecationWarning: Gtk.Window.set_wmclass is deprecated
self.set_wmclass(“Showtime”, “showtime”)
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:56: PyGTKDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for “label” or use a class specific constructor. See: https://wiki.gnome.org/PyGObject/InitializerDeprecations
self.timelabel = Gtk.Label("")
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:57: PyGTKDeprecationWarning: Using positional arguments with the GObject constructor has been deprecated. Please specify keyword(s) for “label” or use a class specific constructor. See: https://wiki.gnome.org/PyGObject/InitializerDeprecations
self.datelabel = Gtk.Label("")
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:59: DeprecationWarning: Gtk.Widget.modify_font is deprecated
self.timelabel.modify_font(Pango.FontDescription(font + " 60"))
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:61: DeprecationWarning: Gtk.Widget.modify_fg is deprecated
Gdk.color_parse(time_color))
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:133: PyGIDeprecationWarning: Since version 3.11, calling threads_init is no longer needed. See: https://wiki.gnome.org/PyGObject/Threading
GObject.threads_init()

(budgie-panel:27033): Gtk-CRITICAL **: 00:21:44.460: gtk_scale_new_with_range: assertion ‘min < max’ failed
sys:1: Warning: g_object_ref_sink: assertion ‘G_IS_OBJECT (object)’ failed

(budgie-panel:27033): Gtk-CRITICAL **: 00:21:44.461: gtk_box_pack: assertion ‘GTK_IS_WIDGET (child)’ failed

(budgie-panel:27033): Gtk-CRITICAL **: 00:21:44.730: gtk_range_set_value: assertion ‘GTK_IS_RANGE (range)’ failed
sys:1: Warning: invalid (NULL) pointer instance
sys:1: Warning: g_signal_connect_object: assertion ‘G_TYPE_CHECK_INSTANCE (instance)’ failed

(budgie-panel:27033): Gtk-CRITICAL **: 00:21:44.730: gtk_scale_set_draw_value: assertion ‘GTK_IS_SCALE (scale)’ failed

(budgie-panel:27033): Gtk-CRITICAL **: 00:21:44.730: gtk_widget_set_size_request: assertion ‘GTK_IS_WIDGET (widget)’ failed

(budgie-panel:27033): Gtk-CRITICAL **: 00:21:44.730: gtk_widget_set_can_focus: assertion ‘GTK_IS_WIDGET (widget)’ failed

(budgie-panel:27033): Gtk-CRITICAL **: 00:21:44.730: gtk_range_set_inverted: assertion ‘GTK_IS_RANGE (range)’ failed
** Message: 00:21:44.959: libsession.vala:50: DESKTOP_AUTOSTART_ID not set, session registration may be broken (not running budgie-desktop?)

(budgie-panel:27033): Bluetooth-WARNING **: 00:21:44.972: Error setting property ‘Powered’ on interface org.bluez.Adapter1: GDBus.Error:org.bluez.Error.Blocked: Blocked through rfkill (g-io-error-quark, 36)

** (budgie-panel:27033): CRITICAL **: 00:21:44.983: budgie_app_sound_control_construct: assertion ‘c_primary != NULL’ failed

(budgie-panel:27033): GLib-GIO-WARNING **: 00:21:44.991: Received property Rate with type y does not match expected type d in the expected interface

(budgie-panel:27033): GLib-GIO-WARNING **: 00:21:44.991: Received property Volume with type y does not match expected type d in the expected interface

(budgie-panel:27033): GLib-GIO-WARNING **: 00:21:44.991: Received property Position with type u does not match expected type x in the expected interface

(budgie-panel:27033): GLib-GIO-WARNING **: 00:21:44.991: Received property MinimumRate with type y does not match expected type d in the expected interface

(budgie-panel:27033): GLib-GIO-WARNING **: 00:21:44.991: Received property MaximumRate with type y does not match expected type d in the expected interface
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:108: PyGIDeprecationWarning: GObject.idle_add is deprecated; use GLib.idle_add instead
GObject.idle_add(
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:111: PyGIDeprecationWarning: GObject.PRIORITY_DEFAULT is deprecated; use GLib.PRIORITY_DEFAULT instead
priority=GObject.PRIORITY_DEFAULT
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:114: PyGIDeprecationWarning: GObject.idle_add is deprecated; use GLib.idle_add instead
GObject.idle_add(
/usr/lib/budgie-desktop/plugins/budgie-showtime/ShowTime:117: PyGIDeprecationWarning: GObject.PRIORITY_DEFAULT is deprecated; use GLib.PRIORITY_DEFAULT instead
priority=GObject.PRIORITY_DEFAULT
sys:1: Warning: g_strsplit: assertion ‘string != NULL’ failed


#4

Showtime issues are a known code issue. That isn’t your issue.

The app sound critical issue is worrying. Check if your budgie desktop package is compiled against the alsa library. On ubuntu that is libasound2-dev

Check also that budgie extras especially weathershow have been compiled using all the build dependencies that should also install the equivalent runtime dependencies


#5

I will probably need to contact the Manjaro Budgie maintainer for most of this. I don’t see libasound2-dev or anything similar in the package manager. I will see what the maintainer says.

Regarding Showtime, should I not be using that app then? That is my second favorite app. :slight_smile:


#6

It doesnt do any harm - so no need to worry. Its just using deprecated code - it still works - just in - say - two years time if we don’t do anything the next version of python/GTK will make it stop working.


made this topic public #7

#8

Hi there, join in your forum to help our users :grinning: .
If needed split this new comments…
I have just yesterday update our budgie-desktop but not used the Solus master repo because i have encountered some issue and seem the solus dev not understand me (https://github.com/solus-project/budgie-desktop/issues/1707) so i can’t grab your patch and build from solus repo. Here my fork .
So for now i not checked the issue with the widget but i have some issue with the dimension of budgie menù and raven menù. Here the warning

[manjaro@manjaro-pc ~]$ budgie-panel --replace &
[1] 1399
[manjaro@manjaro-pc ~]$ ** Message: 16:54:25.392: libsession.vala:50: DESKTOP_AUTOSTART_ID not set, session registration may be broken (not running budgie-desktop?)

(budgie-panel:1399): Gtk-WARNING **: 16:54:35.683: for_size smaller than min-size (34 < 36) while measuring gadget (node box, owner BudgieHeaderWidget)

@fossfreedom sorry for bother you but seem you are the only in the budgie desktop development active to port it into the lastest library ( mutter etc etc ). Say Budgie follow a rolling release model is wrong now for Solus… :expressionless:


#9

hmm - very odd.

I compiled and installed your fork under 19.04.

I restarted the panel - but I did not see the Gtk-Warning.

What is the size of your panel in budgie-settings? - Mine is 39px.

Do you see this warning if you use a theme like EvoPop/Pocillo/Plata ?


#10

Just installed Pocillo ( don’t know this theme before; good work ) and i can’t see the warning now but i continue to not see the raven button at the bottom for open the budgie settings ecc…


#11

Ah. That is because the upstream default now is to hide those options.

In budgie settings you now have a raven section which you can add the “power strip” widget to get that to display in raven.

Upstream have announced though that Power Strip will be removed for v11 of budgie desktop.


#12

Sorry for the delay but temporary i’m in Colombia, not at my home, for work… :expressionless: found it, thank you, i missed this news… but don’t understand why hidden this option :thinking: … now i can debug the applet issue… I have also a problem with our current theme but this is not relevant.
This is my last try with budgie-extras:

now all applets seem work except the wheather applet: still continue to crash budgie.

[manjaro@manjaro-pc ~]$ ** Message: 16:14:01.320: libsession.vala:50: DESKTOP_AUTOSTART_ID not set, session registration may be broken (not running budgie-desktop?)
sys:1: Warning: g_strsplit: assertion 'string != NULL' failed
^C
[1]+  Errore di segmentazione (core dump creato) budgie-panel --replace

this is the only info do the terminal when add the applet


#13

I don’t see “libsoup2.4” in your depends

If adding that doesnt work then can you run budgie-panel --replace via valgrind and attach the log? It will give a better idea of what is causing the segmentation fault.

In ubuntu valgrind is used this way - I guess it is similar/same for manjaro

https://wiki.ubuntu.com/Valgrind


#14

Hi sorry again for delay but last update of vbox cause me a little issue :sweat_smile:

valgrind.log (1.5 MB)


#15

what is the output of:

echo $LANGUAGE

For me it is en_GB:en. The code is expecting $LANGUAGE to return the current language - in this case “en_GB” followed by a “:” and then the equivalent language - in this case “en”


#16

We don’t set this we use only locale
in my case

[manjaro@manjaro-pc ~]$ locale
LANG=it_IT.UTF8
LC_CTYPE="it_IT.UTF8"
LC_NUMERIC="it_IT.UTF8"
LC_TIME="it_IT.UTF8"
LC_COLLATE="it_IT.UTF8"
LC_MONETARY="it_IT.UTF8"
LC_MESSAGES="it_IT.UTF8"
LC_PAPER="it_IT.UTF8"
LC_NAME="it_IT.UTF8"
LC_ADDRESS="it_IT.UTF8"
LC_TELEPHONE="it_IT.UTF8"
LC_MEASUREMENT="it_IT.UTF8"
LC_IDENTIFICATION="it_IT.UTF8"
LC_ALL=
[manjaro@manjaro-pc ~]$

EDIT: before try to add weathershow applet i set this in terminal

export LANGUAGE="it_IT:en_GB:en"
but no help


#17

Probably should be “it_IT:it”

We will need to devise a patch to ensure we obtain the language/locale in a generic manner rather than depend on an environment variable.

It the revised string doesn’t work please rerun the valgrind. It should be different this time and not be crashing in the matcher function that the previous valgrind showed.


#18

Bingo @fossfreedom … set the environment variable ( in my case like this "it_IT:it" ) solve the issue… now weathershow running fine with no crash…
So the problem is in the code where parse the system language.


#19

v0.7.1 of budgie-extras now released - will include a fix for this issue.