Webm video playback

Ok, I’m back again. Newbie to Budgie. I have some webm video files locally. When I go to play these they open in firefox. Not what I want… I want them to open in Celluloid. I found the application setting it it appears the Cellouliod is set to play webm. Indeed, if I right click and use “open with” I can open in Cellouliod. But, I can’t seem to figure out how to make that the default for this file type.

Cancel that. I found it.

Please post your solution and mark it as the accepted answer :wink: