What applet is missing when I try to select hotcorner 'expose all windows'?

I’m trying out Budgie 18.10, and like it so far! (Have been a user of gnome-shell since the beginning).

When I click on the hotcorners symbol, and select a corner to ‘expose all windows’, it gives me a message that says “Missing Applet, this command depends on ano…” And that’s all I can see.

How do I see specifically which applet is missing?

Ah, that’s the result of the shortening of notifications since 18.10. What you need is windowpreviews :slight_smile:
We need to fix the shorter message / info.

Thanks for the quick response. Looking at the ‘budgie applets’ tool, I see a “Previews Applet”, which is installed. (I do not see anything specifically named “window previews”)

That’s the one. You need to add it to the panel via Budgie Settings. After that, it won’t be visible on the panel (iconles), but it’ll do the job.

Thanks, that fixed it!!!

I am testing 19.10 and ran into the same issue, except I knew what the issue was. I went to add the secondary applet so it works and found that it is not available there to add to fix the issue???

I decided I should register and say something in case no one has noticed it is missing.

Is there a way to add applets to the available list in Budgie Desktop settings? Or am I stuck with LTS if I want this to work?

This is a productivity tool, so for me this is a non-starter without it. I otherwise like it better than the LTS version I am also playing with.

Think you have to enable window previews (search the menu for Previews)

Correct. That preview applet needs to be on for this hot corner function to work. But it is not present in the applet list of 19.10 to add to the panel.

It is missing. Is there a way to add it to the selection list?

Previews is no longer an applet - the message is wrong. Its just recently been fixed for 20.04.

Previews needs to be enabled via Menu - Previews. Logout and login and hotcorners should hopefully start working … @vlijm will obviously correct me if I’m wrong here!

Completely correct! in 20.04, the warning is fixed.

Thank you so much. I completely missed that it was no longer an applet, changed to Previews Controls and was moved into the menu @ Menu > Preferences > Previews Controls

It works perfectly fine now that I have set the Previews Controls preferences.

I have figured out though that I am a very very “mousey” user though lol. I tend to set them off by accident very easily because I mouse around too much, but then sometimes have to put some effort into setting them off when I want them. It’s cool that you can set 4 actions up. But I think I would have been cool with one panel applet that does the windows expose. Or one dock applet.

Anyways, I cannot exactly put my fingers to words what the difference is between 18.0.4 LTS and 19.10 but I liked 19.10 better and now that this works it seems 99% a go. I think it is the QogirBudgie window appearance, the new menu icon, and maybe the fonts, and the file manager seems to operate better for me. I don’t seem to be clunking around as much for other navigation options besides clicking.

I would be using on my brand new laptop and my daughter would also be using on her laptop for college. I don’t know if I am over-thinking this or not? When is the next LTS version due out?

not long now - mid April.

Where did you find this setting?
“Menu > Preferences > Previews Controls”

… It’s in the main menu.

Thank you. Of which app?

No app, just the main (applications) menu.

I don’t see a menu or anything about preferences there? I’m on 21.10 BTW.

Wait, I’ll show a screenshot…

Ah, wait the “Preferences” put you on the wrong track.