Acer Aspire V3-551-7844 Keyboard & Touchpad not working if install UB 17.10 or 18.04

I am trying to install Ubuntu Budgie 17.10 or 18.04 on an Acer Aspire V3-551 Laptop

When trying UB 17.10 or 18.04 ( or Linux Mint) from the USB stick, everything is working well…

If I then install Ubuntu Budgie onto the Laptop’s HardDisk , sometime keyboard and mousePad works but most of the time no. Intermittent…

What is different in the version of Ubuntu when I boot from the USB key and or the same Ubuntu version installed from that USB stick to the Hard Drive ?


Found some old article on the web about plaing with GRUB configuration but it didn’t worked

When was the ISO created?

Does the issue occur immediately after the install or after fully updating?

  • Downloaded the iso yesterday,
  • I posted same question on Ask Ubuntu too ( as I tried mint and had the same problem though it was more a ubuntu problem, but took a chance to post here…)
  • I will have to go over the process ( install fresh again ) and pay more attention…

But as 2 times out of 4 approx, it works, doesn’t work, work, reboot doesn’t work, it’s difficult to troubleshoot.

But “everytime” i boot from the bootable USB stick to " TRY " UB, keyboard/mouse pad always work…

For sure if I connect a USB external keyboard or mouse they work…

Was trying to give a 2nd life to a friend Laptop that was using WINDOWS…

What I will do is

  1. Boot 5 times form the UB USB Key ( TRY Ubuntu Budgie mode)
    if keyword always work (and mouse pad)
  2. install UB without updating it…
  3. boot 5 to 10 times to see if keyboard/mouse pad ok… Usually 1 out of 2 it doesn’t work once updated

And we’ll see from there,


one article I found and didn’t worked for me but that could be a lead


Booted 10 times from the UB 18.04 USB stick in TRY UB mode and keyboard / mousepad worked everytime

Now will install it onto the laptop, without updating… And Boot 10 times after


that link also mentioned this:

"PS: This solution stopped working after updating system to Kubuntu 13.04 (and probably will happen updating to Ubuntu 13.04 as well). Even setting grub back to default, rebooting, changing it again and rebooting, the problem persists.

A simple detail has done the magic, after that: go to System Settings > Input Devices > Keyboard > Hardware > change Keyboard Model to something else > Apply > reboot > change Keyboard Model back to Generic | Generic 101-key PC > Apply > reboot. Done!!!"

Does changing to the generic keyboard model work in 18.04?

also saw this on a similar Acer Aspire model:

Setting the Bios touchpad setting to ‘Basic’ fixes keyboard and touchpad issues.

1 Like

I don’t have that option in the BIOS… But I saw some article about upgrading the BIOS to some custom acer bios… Or saw some screen shot about an advanced mode ( that i don’t see in my bios… I will dig more in that direction)

tks !!

White picture is before updating Ubuntu ( Keyboard and mouse pad working) and the black picture is after the Ubuntu Update ( keyboard / mousepad not functional anymore)

Note : the extra mouse and keyboard on the black picture have been connected after I saw the Laptop keyboard and mouse pad were not operational…


With what I found out ( see pictures), I think I need to find a way to modify the bios so I can have those " options in the bios" as there are not there… For now I am using the last bios version of the manufacturer… but saw some videos on youtube with some different bios options with some CUSTOM Bios…


  • Since your Elantech touchpad doesn’t show up in xinput list, it seems there is some issue in the kernel parameters. Please follow me:

    1, Check if you have a file named crc_enabled at /sys/devices/platform/i8042/serio2/ if yes, check if its content shows 0x00
    2. If its 0x00 then change it to 1
    3. Now at /etc/default/grub alter the GRUB_CMDLINE_LINUX_DEFAULT line as GRUB_CMDLINE_LINUX_DEFAULT=“quiet i8042.nomux=1 i8042.reset” and sudo update-grub
    4. Reboot
    Hope this will solve your matter. If not please check this Arch Linux page for more detailed info

On linux Mint I was not seeing this files so could not apply the solution. With Ubuntu Budgie, that had the same problem, those files are there, so I was able to apply this workaround / solution and " it worked"…

1 Like

yay! That is truly an obscure solution - well done the Arch Linux folk!

Just wanted to add, I’m done configuring that old AMD Laptop with UB 18.04 and :

IT ROCK ! Working so welll

The non technical owner who’s windows OS was popping up PopUp, Viruses etc will love it ! And it was dam slow !!

Yea I know I know 18.04 for a not technical user =, not even good with windows ! But it’s stable… so :slight_smile: