Certain Apps UI scaling bugged/broken

New Ubuntu Budgie 18.04 user (coming from Ubuntu Mate) and I really like it so far except…

I prefer VLC to GNOME MPV so go to the software center and get it. Run it to set it up and the UI scaling is wonky. HUGE and obviously wrong. I’ve tried both the Snap version and standard - same issue. So I tried googling the issue and found a potential work-around but hadn’t attempted it yet as I was too busy installing other apps. I then find out, upon downloading and running the MKVToolNix APPImage, that it has the same problem. Massive, obviously wrong resolution for the app itself.

Here is a query to the Ubuntu forum regarding the VLC issue.

I ran into this issue a long time ago when trying out some other distro and, IIRC, it had something to do with the way my display was interpreted by the OS. I didn’t bother trying to truly fix it at the time, I just moved on from that distro. I am using an LG 40" 1080p TV. I checked out how Ubuntu Budgie is discovering/labeling my display and it says - Goldstar Company Ltd 7". It does list it as a 1080p, 60hz which I think is correct but at a 7 inch screen size.

So, anyone know what’s going on here and is there a better way to fix the issue than editing /etc/environment with administrator rights?

Thanks in advance for any help!

Edit to add: Here is the same issue on the VLC forum.

Both VLC and mkvtoolnix are Qt based apps.

Is that a common thread … are all Qt based apps having this issue?
If it is then it does sound like a bug with Qt … perhaps the version in 18.04.

It is worth testing the 20.04 daily and seeing if you have the same issue with VLC via the live session.

20.04 has a much later version of Qt

Thanks for the reply. It probably is a QT issue! I hadn’t considered that. I did end up solving it by adding a line to etc/environment. I was also really looking for an answer as to the incorrect display size issue. But now that I think about it, it probably doesn’t matter or have much to do with this particular issue given that the resolution was set correctly. I am a noob - one that has been running only linux for the past year and a half - but still a noob. So, I am up for learning but I generally only learn when I am forced to, which is stupid.

Is 20.04 fairly stable at this point? Otherwise I think wait on it until it is stable and released. I have enough trouble dealing with things as it is.:slight_smile: Maybe I’ll try it in a virtual machine.

Thanks again for the help!

Its worth just writing the iso to a usb stick and booting with the usb… I.e. dont install if you are not comfortable. You can test stuff via the try ubuntu budgie option when booting.

Right, not sure why I didn’t think of that. Thanks.

Hey while I have your attention - How does the release schedule work? Meaning is 20.04 meant to be stable and ready for release in July when 19.10 loses support? Or in 2021 when 18.04 loses support? Just curious.

Also, am I seeing and reading it correctly - “Modern Intel-based Apple Macs”? Is that to mean that Ubuntu Budgie 20.04 will be able to be installed on Apple Macs? To bare metal as an alternative to OSX or…?

I have had a similar scaling issue using the VLC from snap. Seems the snap version creates a container that doesn’t use the system font configuration. Probably a bug.

Using the Ubuntu package solved the problem for me.

sudo apt-get install vlc

Here is the Ubuntu-Budgie-Forum thread that discusses the problem.

User Codic recommends installing qt5ct package, what didn’t work for me, but might be able to help you. I am copying the relevant part.

"Install the qt5ct package from the repos, then open “Qt5 Settings” from the menu.
There, under the fonts tab, change your font. If you run into a snag,
check Can’t use Qt5ct to change global application style to kvantum
first. "