Desktop Clock on 21.04 Pi4, but not AMD64 Main version

I’m new to Ubuntu-Budgie, but not to linux. Still quite an amateur, though. UB 21.04 on my Raspberry Pi 4 is pretty much a dream. If it had a viable Zoom app, that would be my goto platform. I like to add a large desktop analog clock to my desktops, and I can do that on the Pi4. There I’m using Cairo-clock (2017 Xenial? version, available through /debian/pool/main/c) which performs well in the ARM64 version.

However, doing the same on the AMD64 version of that app (and main AMD64 platform) provides an icon on my Plank dock but nothing visible on the desktop.

I could easily be missing something, or is there some small thing missing from one of the libraries? I have tried adding two other analog clocks but the problem is the same.

Also, “echo $XDG_SESSION_TYPE” says that I am using x11 on both platforms.


I would dare suggest that a xenial package will have issues such as you have observed on a new distribution such as 21.04. Probably would need to recompile on a 21.04 base.

Have you tried a conky clock such as this? Simple Analog Clock Conky -