Failed to start Light Display Manage & Failed to detect the available gpus and deal with any system changes


I’m new to linux and ubuntu, budgie is my first.

I’ve been running it for a month for work and really enjoying it.

Today, I installed lutris and wine so I could play some Celeste.

Worth mentioning is that I have intel Xe gpu but I ran the these commands meant for nvidia by mistake:

sudo add-apt-repository ppa:graphics-drivers/ppa && sudo dpkg --add-architecture i386 && sudo apt update && sudo apt install -y nvidia-driver-515 libvulkan1 libvulkan1:i386

I realized my mistake when it was all done so I removed the packages and ran the intel commands

sudo add-apt-repository ppa:kisak/kisak-mesa && sudo dpkg --add-architecture i386 && sudo apt update && sudo apt upgrade && sudo apt install libgl1-mesa-dri:i386 mesa-vulkan-drivers mesa-vulkan-drivers:i386

And then I rebooted the system as asked
The commands are taken from an official guide here: docs/ at master · lutris/docs · GitHub

That’s when the newbie panic hit me because I got the two errors mentioned in the title and then thrown to the console.

I did some research and tried some solutions

I wasn’t able to get the lightdm service to start

I tried
sudo dpkg-reconfigure lightdm but it doesn’t output or change anything.

I tried reinstalling any package that had lightdm in the name with nothing.

I did some more research and found that budgie uses slick-greeter so I tried reinstalling and reconfiguring it, nothing from that either.

I really hope I can fix this without rinstalling the system, there is so much to lose in the system drive and uncomitted changes that I now regret =")

I would appreciated any help possible.

hmm - kind of depends what else you have tried to fix.

At a minimum purge those PPAs to get to a stable state i.e.

sudo ppa-purge ppa:kisak/kisak-mesa
sudo ppa-purge ppa:graphics-drivers/ppa
1 Like

Thanks for the reply

I purged the PPAs with success and rebooted but the errors remain.

I did some more research and ran these hjncommands
dpkg --print-architecture
Which outputs amd64
dpkg --print-foreign-architectures
Which outputs i386

Is the issue here maybe?

How do I know which one is used, I have a 64-bit system

And the command

sudo service --status-all | grep lightdm

[ - ] lightdm

in theory those will not have impacted anything - those commands just allows 32bit packages to be installed from the PPAs. lightdm and slick-greeter don’t use 32 bit packages.


Do check if you have any remanent of the nvidia drivers installed

sudo apt purge nvidia [press tab a couple of times to complete] 

If any packages are returned you have those packages still installed - you can safely purge those

1 Like

I purged all packages that contain the string nvidia
There were some starting with nvidia and some with libnvidia. All of them removed.

I tried rebooting and reinstalling all packages with the string lightdm or slick in it and reconfiguring the services but nothing

I appreciate your help

you are kind of at a detective stage looking at logs etc

journalctl -ae --full

Scrollback using the arrow keys to see log entries around lightdm - maybe there are messages describing what the issue is.

If you have to reinstall then you could backup the important stuff from your home folder via booting from a live-session and copying what you need to a USB drive.

1 Like

The journalctl full command has lots of output that is difficult me do understand, on the other hand:

journalctl -xeu lightdm
Outputs this:

'Fraid not a lot to go on from that screenshot :frowning:

1 Like

Yep :sweat_smile:

I guess I will be reinstalling budgie tomorrow morning.

Thanks for your help!