Installed WallCH, now Nemo doesn't want to handle desktop icons

So I installed WallCH from GNOME Software to check it out. After a reboot, wallch has an oversized appindicator icon and stops nemo-desktop from autostarting (I have it in autostart in Budgie Desktop Settings, since I updated to 19.10, not clean-installed). Tried purging wallch + rebooting, no difference. I really don’t want to reinstall.
Here’s the error thrown from nemo-desktop in the terminal:

** (nemo-desktop:7235): WARNING **: 08:25:55.706: Current gtk theme is not known to have nemo support (materiav2-dark-pocillo) - checking...

** (nemo-desktop:7235): WARNING **: 08:25:56.055: Desktop already managed by another application, skipping desktop setup.
To change this, modify org.nemo.desktop 'ignored-desktop-handlers'.

@fossfreedom you may be able to help here

logout and login - can you double check that nemo-desktop isn’t already running - ps -ef | grep nemo

If it is running - then make sure you haven’t just turned off desktop-icons in budgie-desktop-settings

Here: codic 13217 6887 0 08:38 pts/0 00:00:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn nemo
So yes, it is running. Budgie Desktop Settings has no such option:

The Desktop section used to be there, but isn’t since I upgraded to 19.10
Logging out and in didn’t help.
I really don’t want to reinstall :frowning:

using dconf-editor make sure this keys value is “NEMO”

That will make the desktop option reappear in budgie-desktop-settings

Make sure this key has the values shown

For the first one, it was “NONE” changed it to NEMO, now it shows in Budgie Settings. For the second one, I have this:

What should I change?

odd - do check that you havent uninstalled the UB packages:

sudo apt install --reinstall budgie-desktop-environment budgie-desktop-common

Maybe I did.

[sudo] password for codic: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libdee-1.0-4 libkeybinder0 libunity-protocol-private0 libunity-scopes-json-def-desktop libunity9
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  budgie-desktop qt5-gtk2-platformtheme qt5-style-plugin-cleanlooks qt5-style-plugin-motif qt5-style-plugin-plastique qt5-style-plugins
The following NEW packages will be installed:
  budgie-desktop budgie-desktop-common budgie-desktop-environment qt5-gtk2-platformtheme qt5-style-plugin-cleanlooks qt5-style-plugin-motif qt5-style-plugin-plastique
0 upgraded, 8 newly installed, 0 to remove and 6 not upgraded.
1 not fully installed or removed.
Need to get 1,403 kB of archives.
After this operation, 1,660 kB of additional disk space will be used.
Do you want to continue? [Y/n] 

Reinstalling now
Rebooting to check

Rebooted, same issue :frowning:

And the default value & current value fields are now the same as mine?

For your first screenshot, I changed them, for my second, see my above reply; I have a custom value set, but the defaults seem to be not the same as yours :stuck_out_tongue:

sounds like you’ve got another package overriding UB’s value.

Make sure your current-value field is the same as my default

Alright, doing that now.

Wait, now icons work!!! Thanks!

@fossfreedom the only problem is, the icons are smaller then before. The context menu seems to have more options.

you now have UB’s defaults - that’s why the context menu is different and the default icon view size

Open Nemo - tap the alt key to display the menu and then choose edit - preferences. Change the default zoom level to what you prefer to use.

Ah, okay, thanks so much :slight_smile: