Internet only working through VPN

I have an interesting issue right now. I restarted my computer and logged back in. The wifi connected just fine, and detects all of the surrounding networks… But there is no software access to the internet connection like there is a firewall or something up.

When I turn on my VPN though, the internet works fine. Anyone have any idea what the problem is? I mean, I don’t mind using my VPN in the meantime but it slows down my work a bit.

It is also worth noting that I just tested and I can plug in my iPhone and use it’s wired connection just fine without a VPN…

Hi, an interesting one for sure. A few tests you can do:

  1. Reboot your network equipment: Router. Access Points, Switches, ISP modem/router/fiber box. And try again
  2. If still having the issue, reboot your PC at this point and try again.
  3. If still having the issue, boot your PC with a USB thumbdrive loaded with any linux distribution, connect to Wi-Fi and try again.
  4. if still having the issue, try to see if it is a DNS issue. Open a terminal and try the following: “ping 1.1.1.1” if you get response, your network is actually working. Then try “ping cloudflare.com” and if this does not give you a response, then we can concentrate on DNS settings.
  5. If still having the issue, try to delete the Wi-Fi network and re-join it. Then try again.
  6. If still having the issue, go to your Wi-Fi network, click the gear icon, and in IPv4, deselect Automatic on DNS. and instead enter 1.1.1.1 . Then try again.

Hopefully some of the steps above help you.

2 Likes

Hi thanks for getting at me, I tried several of of these during my troubleshooting. Yeah I was getting a response during pinging, and like I said the connection worked with a VPN. I did several restarts, and was had just thought to delete the stored connection because I noticed the coffee shop connection working earlier.

The issue appears to have already fixed its-self though after I used my iPhone as a connection, or when I connected at the coffee shop… Weird.

If it happens again to see if it was either the wired connection, or the alternative wifi connection that got things running again.

If someone is searching for a solution and find this thread try hooking up to an alternative wifi connection, or deleting your stored connection and connecting again, or plugging into a wired connection then going to wifi again. One of the above should help.

Thanks again I appreciate your attention on this. @ilvipero