Neither VMware Player 15 or 16 work on ubuntuBudgie 20.04.1 LTS

Just wondering if anyone else has had this problem & if there are some pointers to get it working.
Didi the usual;

  • sudo apt install build-essential
  • sudo ./Vmware-Player-*.bundle (using each different version 15 & 16)

Install appears to go okay and confirmation message etc.

VMware fires up;

  • won’t open already created VMs
  • can create new VMs but again, won’t open them

Hi and welcome

Seems to be working just fine - I am using QEMU on a UB 20.04.1 host

I have installed v16 of the VMWare bundle within a 20.10 UB QEMU guest

As you can see - I have install Slitaz within VMWare. I powered it down and just double clicked the VM to restart

So, I’m not really sure why you are having issues - seems to be working just fine - even having a virtual machine within a virtual machine!

Thanks David,

Appreciate your checking.

Tbh I’ve never tried using qemu-kvm before so that’s new for me. I will give that a try.
Are there advantages to using QEMU? Is it as easy as 1 command “apt install”? Or a more complicated setup?

Previously used VMware Player 15 on a clean Ubuntu 20.04.1 and it worked well.
Initially because VMware Player 16 is the newer version I thought it might be that, so tried v15.
It appears to go through the installation setup, then nothing.
What’s interesting is Vbox worked just fine.

QEMU is available and maintained by Canonical - so its directly available from the regular repos and doesn’t need a third-party and its complexities.

That will get you going.

Another simpler version of QEMU is gnome-boxes - it still uses the same linux capabilities of QEMU but in a much simpler way for beginners.

Thank you SO so much!
This is awesome…learning ALL the time.

hello again David,

Thanks for your suggestion wrt QEMU/KVM.
Went with the QEMU rather than gnome-boxes after reading up a bit.

Got everything working nicely!
Very happy.

Rgds, M.

I was wondering if my having a minimal install may cause these issues?