No Background on Login Screen

Yes, that’s where I tried changing the background.

Maybe rights are not correct on the picture file you try to use as a background.

Login screen is managed by user « root ». So the picture file should be « readable » by anyone ( something like rwxr-xr-x or 755 ). Also that file should be in a folder « root » have access to.

ls -l /path_to_folder/where_is_your/background_picture

The one I had changed it to is 644. I’ve tried reverting to one of the standard backgrounds, and that isn’t working either.

Please can you double check that all the UB theme and configuration packages are installed correctly?

sudo apt install --reinstall ubuntu-budgie-desktop budgie-desktop-environment budgie-desktop-common ubuntu-budgie-themes slick-greeter budgie-lightdm-theme

Done; the background is still black.

This amounts to an annoyance more than anything. I’m grateful for trying to get this figured out; don’t get me wrong, I would like to get it figured out. However, it’s not causing any other issues, so if nothing works, it is livable.

Have you got a file /etc/lightdm/slick-greeter.conf ? if so what is its contents?

[Greeter]
background=/usr/share/backgrounds/Xplo_by_Hugo_Cliff.png
draw-user-backgrounds=true

hmm - what is the output of the following?

gsettings list-recursively x.dm.slick-greeter
x.dm.slick-greeter group-filter @as []
x.dm.slick-greeter hidden-users @as []
x.dm.slick-greeter xft-dpi 96.0
x.dm.slick-greeter show-quit true
x.dm.slick-greeter show-hostname true
x.dm.slick-greeter play-ready-sound ''
x.dm.slick-greeter enable-hidpi 'auto'
x.dm.slick-greeter theme-name 'Pocillo-dark'
x.dm.slick-greeter other-monitors-logo ''
x.dm.slick-greeter font-name 'Ubuntu 11'
x.dm.slick-greeter activate-numlock false
x.dm.slick-greeter xft-hintstyle 'hintslight'
x.dm.slick-greeter background '/usr/share/backgrounds/Xplo_by_Hugo_Cliff.png'
x.dm.slick-greeter draw-user-backgrounds true
x.dm.slick-greeter icon-theme-name 'gnome'
x.dm.slick-greeter logo ''
x.dm.slick-greeter show-power true
x.dm.slick-greeter draw-grid false
x.dm.slick-greeter screen-reader false
x.dm.slick-greeter show-a11y true
x.dm.slick-greeter show-clock true
x.dm.slick-greeter onscreen-keyboard false
x.dm.slick-greeter show-keyboard true
x.dm.slick-greeter xft-rgba 'rgb'
x.dm.slick-greeter background-color '#000000'
x.dm.slick-greeter high-contrast false
x.dm.slick-greeter xft-antialias true

Mmm interesting.
Your login screen is set to display the same background as selected user, it means the user’s desktop background. What is that file and is it accessible to root for lightdm to display it ? Is your personal folder encrypted ?

Reminds me of [Request] A default way for changing wallpaper every few minutes

background=/usr/share/backgrounds/Xplo_by_Hugo_Cliff.png

↑ this, is a default setting as stored in dconf keys, but overiden by /etc/lightdm/slick-greeter.conf

Mine for exemple contains :

[Greeter]
draw-grid=true
draw-user-backgrounds=true
background=
show-a11y=false
show-power=false
theme-name=Adapta
icon-theme-name=Papirus-Dark
activate-numlock=true

Whilst dconf settings regarding x.dm.slick-greeter are different :

coeur-noir@asgard:~$ gsettings list-recursively x.dm.slick-greeter
x.dm.slick-greeter group-filter @as []
x.dm.slick-greeter hidden-users @as []
x.dm.slick-greeter xft-dpi 96.0
x.dm.slick-greeter show-quit true
x.dm.slick-greeter show-hostname true
x.dm.slick-greeter play-ready-sound ''
x.dm.slick-greeter enable-hidpi 'auto'
x.dm.slick-greeter theme-name 'Pocillo-dark'
x.dm.slick-greeter other-monitors-logo ''
x.dm.slick-greeter font-name 'Ubuntu 11'
x.dm.slick-greeter activate-numlock true
x.dm.slick-greeter xft-hintstyle 'hintslight'
x.dm.slick-greeter background '/usr/share/backgrounds/Xplo_by_Hugo_Cliff.png'
x.dm.slick-greeter draw-user-backgrounds true
x.dm.slick-greeter icon-theme-name 'gnome'
x.dm.slick-greeter logo ''
x.dm.slick-greeter show-power true
x.dm.slick-greeter draw-grid false
x.dm.slick-greeter screen-reader false
x.dm.slick-greeter show-a11y true
x.dm.slick-greeter show-clock true
x.dm.slick-greeter onscreen-keyboard false
x.dm.slick-greeter show-keyboard true
x.dm.slick-greeter xft-rgba 'rgb'
x.dm.slick-greeter background-color '#000000'
x.dm.slick-greeter high-contrast false
x.dm.slick-greeter xft-antialias true
coeur-noir@asgard:~$ 

( here I had manually changed values in dconf for draw-user-backgrounds, activate-numlock )

So you should check what’s in your /etc/lightdm/slick-greeter.conf as this is the file written by the login screen utility which overrides default lightdm conf.

Okay, this is interesting.

I changed my desktop background by “right clicking” on the desktop, then I drug the picture I wanted to use from a directory to the pictures tab of the Settings window. When I look for the file in the Pictures directory, it isn’t there, but I do still have the file in the original directory. Now, I just copied that file to the Pictures directory, and there are two copies listed under the pictures tab of the Settings window. How do I clear the tab of the non-existing file?

Draw user backgrounds was enabled in the Login Window app; has been since I first opened it. I’ve disabled it there, but gsettings still lists it as enabled.

I posted the contents of /etc/lightdm/slick-greet.conf above. It has all of three lines in it. draw-user-backgrounds has been changed to false there.

Since that change, the Xplo file displays.

I’ve changed the background to one in ~/Pictures, and it displays. If I change the background to a file in another directory with the same permissions as one in ~/Pictures, it won’t display.

How Gnome came to such a mess for setting desktop or login-screen background picture is a mystery to me…

Gnome expects you to use « settings » then « background » for that AND eventually only pictures at the root of folder ~/Pictures. Nowhere else.

When you go through right-click on desktop → change background → you browse to a folder where to find the picture_of_your_choice.jpg → this makes there a duplicate of it named picture_of_your_choice (copy).jpg → then uses that copy as background.

Still following ?

If you delete the …(copy) file you end up with no background. I guess you can delete the original one.

Okay, I think I follow, but I’m not finding any files anywhere with (copy) in the name.

When I drag and drop a file from Nautilus to the Gnome settings window (specifically, background images), where is that file copied to? I tried searching for the original file name in Nautilus, and I’m only finding the original location.

Good question, I’ve tried your method with D’n’D on gnome-settings background, picture tab, and as you I can’t find my pictures for the moment…

Ok ! With drag and drop, it ends up in :

~.cache/gnome-control-center/backgrounds/ddc99203eab7e8915d182c8e8c42b603ea10691ebfc1443fc21837cc3dec34e1

I’ve found the answer in dconf editor /org/gnome/desktop/background/

Edit, later : and while using that picture from ~/.cache… as desktop background it no longer appears on login-screen :-/

1 Like

And I think I’ve found out why !

It seems by default the rights on folders

~/.cache
~/.cache/gnome-control-center
~/.cache/gnome-control-center/backgrounds

don’t give file acces to others !

So make sure those folders « let » root [ edit : it’s not root user but lightdm user ] read their content by chmod -R o+rX ~/.cache

Then you can even replace the original folder backgrounds by a sym-link of same name ( and with those right rights ) to any of your personal folder containing wallpapers pictures :wink:

So now in « parameters / backgrounds / pictures tab » are displayed my wallpapers from a subfolder in my ~/Pictures folder.

Back at it again this morning.

Bravo!

I simply deleted the cache file(s), now I only have single copies of the images I D’n’D to the tab: those that I copied from the original folder to ~/Pictures.

Nice ! But remind that lightdm may not have access to these pictures ( in case you’d want to use the « user’s background » option ) unless you modify permissions on these folders.

I am as stubborn as Gnome is irritating sometimes, lol.

I can’t understand why it’s not possible to browse the whole Pictures folder ( and, so, its sub-folders ) straight from gnome-control-center.

But thanks to your question I now have a workaround :wink:

…and of course, it has changed between 18.04 and 19.10…

So now your personal pictures will fall into
~/.local/share/backgrounds
So you may replace this folder by a symlink to one of your personal folder where are stored your own wallpapers.
You’ll then have the choice between those and the by-default ones, which is nice.

1 Like