NVIDIA 390 black screen

has anyone actually reported this to canonical (launchpad) or nvidia themselves ? link to the bug report?

this looks like a candidate bug report with a long discussion

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1752053

It has just been marked as fix released though. People are still reporting black screens post that release.

… but as the triager says - if you still have an issue then report it as a new bug report - adding to that bug report above will just be ignored.

Got it. Will report as a new bug…

Thanks - please drop a link to your new report here. Cheers.

Also found another nvidia 390 lightdm bug report that people can monitor: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1756226

ok - more advice here to try - people have found success using comment #20 here

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1756226

Seems to be a consistent failure all round of the 390 series of proprietary drivers from nvidia.

Ok - what I found that works for me (recording this in bug report https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1764005

I am using a GTX960M graphics chipset

I switched to a TTY (CTRL+ALT+F4) and logged in a TTY

Checked and if necessary installed nvidia-prime i.e.

sudo apt install nvidia-prime

Then I ran

sudo prime-select intel

Rebooted and all was well

If that doesnt work I also found I can use the opensource nouveau drivers successfully

i.e. in a TTY

sudo apt-get remove nvidia-*

NOTE - the - in the above command

reboot and all is well

1 Like

I went with the

sudo prime-select intel

method and have a working system again.
What I find strange is that everything (both Intel and Nvidia graphics) work fine under 17.10

I’m on a HP ZBook 15

niels@zbook:~$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208GLM [Quadro K610M] (rev a1)

@nroetert the very latest from today is that the canonical dev has identified the issue and says it is straightforward to fix. So we are all just waiting for the update to be pushed hopefully very soon.

I saw a lot of Nvidia related updates come in yesterday, but those didn’t help.
Guess you are refering to a near future update, hanging on.

My bug report above is detailing the current investigation.

That was the same situation for me as well.

The fix is the nvidia-prome package which is currently in the proposed repo together with a revised Nvidia 390 driver. I have no idea though if the archive admins will accept it into the main repository for the release of if it will appear some time after the release.

Is the revised Nvidia 390 in repo’s yet or is it pending?

As I said they are in the proposed repo.

I wasn’t sure if that was relating to the prime package or the full drivers. Thanks!

Just had notification that the nvidia-prime package has been released - so in a few hours after the mirrors have picked this up you should be above to update with this and switch back and forth between intel and nvidia drivers.

If you continue to have a black screen this is a new issue that is not solved with this update. In this case please report it to launchpad otherwise the developers will not be aware of your issue.

thanks

1 Like

Works for me :facepunch:

Screenshot%20from%202018-04-24%2011%3A00%3A38

1 Like

Fabulous! Nvidia 396 drivers working well for me now :slight_smile:.

I have a NVIDIA Corporation GP107 [GeForce GTX 1050] card and ubuntu 19.04 installed (18.10 gave the same issue). I tried many proposed solutions, including the one above. Nothing worked.

I finally found a solution for this Nvidia driver issue (on ubuntu 18 and 19). See instructions at the top at https://ubuntuforums.org/showthread…nvidia+drivers, it worked for me!

1 Like

neat! Congrats on finding that and sharing :slight_smile:

1 Like