Spotify song covers not showing on raven

when I play songs on Spotify they are shown in the raven with the media playback controls but it doesn’t show the covers, instead it shows a music icon and previously it did show the covers.
please help me

On Spotify ?

Do you mean through an application named Spotify ? Is it a .deb or a .snap application ?

Or do you mean from the website ? And then, which web-browser do you use, Chromium, Firefox or else ?

Also, when you you say that it previously did show the covers, do you mean previously on your current UB install, or on a previous system?

I tried the both the snap and the .deb of Spotify and both show just the generic music icon for me too (but other players the album covers correctly) so it doesn’t appear to be a snap issue this time…

it’s a .snap aplication

Could i try reinstalling the app?

Actually, I think this is a question for @fossfreedom or someone else maybe… I noticed on Github, there was a fix for this in MprisGui.vala to fix Spotify album art:

Here’s where my ignorance of linux really shines through…

I downloaded that and compiled it, and it did indeed fix the album art for both the snap and .deb version. I am just not sure how it works, when this gets automatically updated, if it should have already been updated on my system, if i messed something up, etc…

Correct - that fix will land in budgie-desktop 10.5.2 when its released by upstream

Note - issue is that Spotify changed the way it handled coverart - after budgie-desktop v10.5.1 was released.

1 Like

Samlane, now that you have pointed this out, I need this Raven/Spotify issue solved as well! Would you post a quick tutorial for dummies like me how to do this? If you spell it all out like I was a 5 year old, I won’t take offense. I’m assuming it would work for my flatpak install of Spotify, just as it worked for your snap install.

To start, I used @fossfreedom’s instructions from his post as follows:

Make sure your package management system is up-to-date and install the dev scripts

sudo apt update
sudo apt install devscripts

now run to enable the source code files from the repo:

software-properties-gtk

Click on the “Source code” checkbox
Click Close, Reload

Install all the development package dependencies:

sudo apt build-dep budgie-desktop

To get the current package source code (no need for root access from now on):

apt-get source budgie-desktop
cd budgie-desktop-10.5.1

To compile first setup your build environment:

mkdir build
cd build
meson --buildtype plain --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc ..
ninja -v

To install, make sure you are in the build folder you created previously:

sudo ninja install

Now what I did to update Raven for Spotify:

cd
git clone https://github.com/solus-project/budgie-desktop
cp budgie-desktop/src/raven/mpris/* budgie-desktop-10.5.1/src/raven/mpris/
cd budgie-desktop-10.5.1/build
ninja
sudo ninja install

Log out and log back in and it should work now.

Also note, cloning the entire Solus budgie desktop is not necessary. You could just go to https://raw.githubusercontent.com/solus-project/budgie-desktop/master/src/raven/mpris/MprisGui.vala and save that page, overwriting MprisGui.vala in ~/budgie-desktop-10.5.1/src/raven/mpris/, but I did it originally the first way.

Link to his original post:

Actually, this may not work correctly as written anymore. I’ll have to defer to @fossfreedom on this one.
This:

sudo apt build-dep budgie-desktop

seems to failing and giving unmet dependencies errors.

Just make sure you have the source code checkbox ticked and ensure the universe repo is also ticked in software-properties-gtk then you run

sudo apt update

and the development build libraries will be installed with

sudo apt build-dep budgie-desktop
1 Like

The first time i tried, i got a message saying:

The following packages have unmet dependencies:
builddeps:budgie-desktop : Depends :libmutter-6-dev but it is not going to be installed.
E: Unable to correct problems, you have held broken packages.

I restarted from scratch, tried again. I got this:

Get:167 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 gnome-settings-daemon-dev amd64 3.36.1-0ubuntu1 [6,664 B]
Get:168 http://us.archive.ubuntu.com/ubuntu focal/main amd64 libgnome-bluetooth-dev amd64 3.34.1-1 [29.6 kB]
Get:169 http://us.archive.ubuntu.com/ubuntu focal/main amd64 libpeas-dev amd64 1.26.0-2 [23.0 kB]
Fetched 35.2 MB in 1min 40s (353 kB/s)                                         
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/libg/libglvnd/libgles-dev_1.3.1-1_amd64.deb  Undetermined Error [IP: 91.189.91.38 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
E: Failed to process build dependencies

After this, I re-ran the command, and this time it completed without errors. Problem with the US servers maybe? Anyways, works now, thanks.

Eeesh! Thanks for the heads up :face_with_raised_eyebrow:

You should be ok. Since I posted I was having the issue I was able to do this on a fresh install without error. So that means the issue was either temporary, or - maybe more likely - on my end.

Hi all - I’m now looking at pushing a future update to 20.04 to resolve this.

I need a bug report though to fix against. Please can you run:

ubuntu-bug budgie-desktop

Let me know what the bug report number is. TIA

Reported under Bug #1895720

Spotted in the news, a Spotify solution I didn’t know I needed: