Super Key won't Bring Up the Overlay

Hi I’m having issues with the super key not bringing up the search overlay.

I have the exact situation shown in the issue above, but the solution does not fix my issue. The key is set to ‘Super_L’ and I think that should be correct for me.
I also tried this keyboard - Super key not working in Ubuntu 20.04 - Ask Ubuntu

The super key works for all other shortcuts but just won’t bring up the overlay.

Here is neofetch output.

Thanks in advance.

The super key opens the menu … the dconf key may say ‘overlay’ but it is mapped to open the menu.

Ok I see. It isn’t opening the menu then. How can I get it to open the menu again?

Are you saying the menu key has never worked before?

Are you sure you have the correct keyboard layout?

For 20.04 use system settings. For 22.04 same as below but use budgie control center

Choose System Settings. Click Keyboard Layout. The Keyboard Layout window opens. Click the plus (+) sign in the bottom-left corner to open the available keyboard layouts.

It used to work. It just stopped working today and I did not change anything

Also, how can I get to the settings since I can’t open the search menu?

Huh? Just click on the menu … top left UB icon.

Have you done any updates?

Have you rebooted?

Have you checked if its user specific or system wide? I.e. create a new user and login with that to see if the same issue occurs.

Have you checked if it isnt just a physical issue? I.e. boot into a live iso. If it doesnt work there then you have a physical not software issue.

There is no icon there which is the strangest thing. How do I get the menu to come back? I have updated and rebooted but I have not tried creating a new user yet.
There is also not a hardware issue because the super key works for everything except opening the menu.
I suspect that somehow the menu process got killed or something like that. How can I turn it on again?

Press control alt t

That will open a terminal



Check the panel applets to see if the menu applet is there. If not add it.

Thank you very much. Somehow, the menu applet got removed from the panel somehow. Any ideas how that could happen?

We have had reports of applets disappearing usually because of a system freeze or crash or some people doing a forced power off / power cut.