Wifi Card Plugged In, Not Detected in 18.10 Budige

My Machine: HP ENVY dv6t-7300 CTO Quad Edition Notebook PC (link: https://support.hp.com/us-en/drivers/selfservice/HP-ENVY-dv6-Notebook-PC-series/5363716/model/5363718)

I have tried literally everything to get my wifi card to work again…

  1. Checked network settings to see if there is something I can toggle on. (nope)

  2. Checked lspci to see all connected devices (wasn’t included)

  3. Tried installing the ALL the drivers listed on the support website (made for windows 8.1, also were .exe files. Tried wine and nothing happened)

  4. Opened up my laptop, checked to see if card was plugged in (yes) then flipped around those two wires that latch onto the card labeled with a 1 and 2, restarted (and it didn’t work). Then I flipped them back and restarted (still didn’t work).

I am truly at a loss of what the problem could be. I’ve thought of every solution I can…PLZ Help!

18.10 has gone end of support a year ago.

Please use a supported version of ubuntu budgie … 18.04.4 or 19.10